2

I'm using Ubuntu 18.04.1 LTS with unity user interface

kernel 4.15.18-041518-generic
gtk amd64 version 3.22

I installed two themes from b00merang: https://b00merang.weebly.com/windows-10.html -Windows-10 black theme and -Windows-10 light theme

I have no problem with black theme. With white theme however, the text of desktop shortcuts/files is unreadable.

Here an example image showing with black theme:

Windows10 dark theme

Here is the problem with white theme:

Windows10 light theme

Both themes were put in ~/.themes/

0

This answer is only for the mentioned theme in the question, i.e "Windows-10-master" Theme.

in this particular theme, to change the text color of folders on Desktop.

i have saved my themes in /usr/share/themes/ you need to replace /usr/share/themes with ~/.themes in the below example as you saved your themes in ~/.themes/

I have created a nautilus.css file in the folder
/usr/share/themes/Windows-10-master/gtk-3.20/apps

made the content in this file as below

.nautilus-desktop.nautilus-canvas-item {
    color: blue; # <--------- here in the place of "blue" you can put any valid color you want
}

Save the file & Close.

now, Open the file gtk.css in the folder/usr/share/themes/Windows-10-master/gtk-3.20/

add the below line at the end,
@import url("apps/nautilus.css");

after adding this line, last 3 lines should look like this.

@import url("gtk-contained.css");
@import url("apps/gnome-terminal.css");
@import url("apps/nautilus.css");

Save the file & Close.

Reboot to see the change.

enter image description here

enter image description here

enter image description here

enter image description here

1

The issue here is with the text colour of the theme.

You can change this quite easily, since GTK+ themes (as of GTK+ 3) are simply CSS (Cascading Style Sheets).

You can change the colour to

#FFFFFF;

as opposed to

@desktop_item_fg;

in this section:

.caja-desktop,
.nemo-desktop.nemo-canvas-item,
.nautilus-desktop.nautilus-canvas-item {
    color: @desktop_item_fg;
    text-shadow: 1px 1px @desktop_item_text_shadow;
}

Or change the value of the variable:

@define-color fg_color

You might also want to consider a more up to date theme. You can find several of the same kind on gnome-look.org.

  • There is no desktop.css file into the app folder actually, can you please have a look at this? – ExtrUnsk Oct 14 '18 at 5:31
  • @ExtrUnsk if this answer didn't solve your question, you shouldn't mark it as solved with the "tick." I haven't (yet) downloaded the theme to check it for myself, but see if the updated answer works for you. – RolandiXor Oct 16 '18 at 4:08
  • Thank you for the answer. I tried changing desktop_item_fg to #ffffff in gtk.css and every other css file including it but it did not work. Same for second option. The only thing that made text color to change was setting @define-color theme_fg_color #ffffff in the gtk.css file BUT all the text in nautilus also went to white so this is not an option. – ExtrUnsk Oct 17 '18 at 17:06
  • If you have time to download the theme to check that would be great, otherwise I will just try to find a similar theme. Please let me know! – ExtrUnsk Oct 17 '18 at 17:06
  • @ExtrUnsk that's probably your best option, short of filing a bug report. I don't think I would be able to get a much better result, and it would take a while digging around and playing with values to get it right otherwise. All the best! – RolandiXor Oct 17 '18 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.