0

After doing an update today, I can no longer login after a screen lock. I enter my password, the screen goes black and then returns to the login screen. The only way to login again is to reboot.

Among the things I've tried:

apt-get remove gdm3 apt-get install gdm3

Tried swithcing to lightdm apt-get remove lightdm apt-get install lightdm

First lightdm login worked, but then I get an error dialog about the screen settings not working. There was no way to exit the dialog, so I end up re-installing gdb3.

I turned on debugging with gdm3, but I didn't see anything obvious in /var/log/syslog.

This is on a laptop with the following:

       *-display
            description: VGA compatible controller
            product: GK104GLM [Quadro K3100M]
            vendor: NVIDIA Corporation
            physical id: 0
            bus info: pci@0000:01:00.0
            version: a1
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
            configuration: driver=nvidia latency=0
            resources: irq:16 memory:cd000000-cdffffff memory:50000000-5fffffff memory:60000000-61ffffff ioport:5000(size=128) memory:ce000000-ce07ffff

Any ideas?

  • Can you log in as another user? – Stephen Boston Oct 12 '18 at 21:03
  • No, I can't. In fact I created a test user so that I could be sure there was no old config files causing problems. I can do ctrl-shift-f3 and login that way, ie outside of xwindow. Long ago I would just use startx start the xwindow system and debug that way. I dont' know what to do with gdm3. I turned on debuging in /etc/gdm3/custom.conf. There is noting in /var/log/gdm3. Syslog contains some errors: (EE) open /dev/fb0: Permission denied, (EE) modeset(0): failed to set mode: Permission denied – Andrew Howell Oct 13 '18 at 2:50
  • To clarify. I can login as the test user, but when the screen locks, I can't get back in. – Andrew Howell Oct 13 '18 at 2:52
  • You could disable screen lock. I know that is not what you're looking for but if this issue is standing in the way of other work... You could delay further research until you have time for it. These little glitches can be so irritating, I know. – Stephen Boston Oct 13 '18 at 14:35
  • I restart lightdm with systemctl restart lightdm. gdm3 might be the same. – Stephen Boston Oct 13 '18 at 14:37

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.