I want to use a USB-Serial adapter like this: https://www.alibaba.com/product-detail/FVT-USB-Linker-programmer-for-Car_60438143730.html?spm=a2700.8443308.0.0.49923e5f3vy0O0

With Wine, to configure/program a skateboard ESC.

I've downloaded Wine and gotten the program running like this: https://i.stack.imgur.com/VEOl2.jpg

So the program is a little cut of, and then you can also see that the Serial adapter is not recognized!

I-ve tried using the command

ln -s /dev/tty0 ~/.wine/dosdevices/com1


ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com

With no luck. How do I go about fixing this issue? Best regards.

  • WINE is no good for that. A (Windows) VM may work with USB passtrought and drivers installed. I did it once to use Windows software to flash a tablet (the software also runs with Wine but wouldn't detect the tablet).
    – user880592
    Oct 12, 2018 at 18:17

1 Answer 1


Your attempted solution of

ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1

would have worked in earlier versions of Wine. This changed in Wine 2.8, now you need to manage the mapping using RegEdit.

WINEPREFIX=~/.wine wine regedit

Add a string entry under HKEY_LOCAL_MACHINE\Software\Wine\Ports with a key of COM1 and a value of /dev/ttyUSB0.

This problem is called out specifically in this blog post: https://www.scivision.dev/wine-serial-port-links/

And also mentioned in the official user guide: https://wiki.winehq.org/Wine_User%27s_Guide#Serial_and_Parallel_Ports

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .