My gnome-terminal appears to have stopped working. Clicking the icon, Ctrl+Alt+T, and Alt+F2 -> gnome-terminal all have the same effect: the mouse changes to a spinner, the icon shows that gnome-terminal is loading, but then after a few seconds, things go back to where they were before.

I've read a number of threads linking this to a locale setting issue, but none of those answers have worked for me (sudo locale-gen --purge, resetting the locale, etc.).

As with many of the other people who have reported a problem like this, the error message I get from MATE terminal is this: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached .

I also tried uninstalling and reinstalling gnome-terminal to no avail.

On a whim, I tried sudo gnome-terminal, and this loads up correctly. From here, I can login username and now I can use my terminal normally. I tried cp /etc/skel/.bashrc ~/ + relogging to see if maybe there was something wrong with my .bashrc; this changed nothing.

I'm not sure if it's related, but I'm also now receiving an error message that my default keyring hasn't been unlocked upon logging in, which never happened before.

What could be causing this?

3 Answers 3


I got this - it coincided with suddenly needing to enter a Keyring password on every login. I think that started after installing chrome-remote-desktop.

It also screwed my sound - no sound device:

The fix is here: Installing Google Chrome Remote Desktop messed up my box

All I had to do was sudo rm -rf ~/.config/chrome-remote-desktop and reboot.

I got my sound back and I could launch gnome-terminal again

chrome-remote-desktop was the culprit


In terminal, try this...

cd                              # change to home directory
ls -al .*auth*                  # list some important files

-rw------- 1 decker decker 405834 Oct 11 07:39 .ICEauthority
-rw------- 1 decker decker     58 Jun 23  2017 .Xauthority

The "decker" name might be slightly different, depending on your actual username.

If it shows anything other than rw, or different usernames, you'll need to either:

cd                               # change to home directory
sudo chmod 600 .*auth*           # set to rw
sudo chown decker:decker .*auth* # change the username if need be

Regarding the keyring, make sure that your actual login password is the same for the Default/Login keyring(s). Use the Password and Keys (18.04.1) app to change it.

  • 1
    Thanks! It does show rw, so it doesn't look like that fixed the issue. I ended up just reformatting the drive because I couldn't wait much longer due to some deadlines, so I guess it'll stay a mystery. After some further digging, I found that my sound was messed up and the driver was now listed as something related to chrome-remote-desktop, so I'm curious if something got broken there. Thanks for the ideas!
    – deckeresq
    Commented Oct 14, 2018 at 0:12

I had the same problem. Solved it easily. The problem was that I had a different date format set in the locale (languages), but did not have that language installed. So, I had

  • Language: English (US)
  • date format: English (UK)

and had only English (US) language installed. When I installed the English (UK) language, everything went well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .