I can start none of

  • $ unity-control-center
  • $ gnome-control-center

The output is bus error (core dump created), though both of them are re-installed already. On my MacBookPro6,2 with Ubuntu 16.04.5, I also do not see the battery icon. When I try to open the "system settings" via the main menu top right then nothing will happen.

Analyzing the problem, I tried $ sudo apt-cache depends unity-control-center and the prompt was (translated status words from German):

  Depends: libaccountsservice0
  Depends: libatk1.0-0
  Depends: libc6
  Depends: libcairo2
  Depends: libcanberra-gtk3-0
  Depends: libcanberra0
  Depends: libcheese-gtk25
  Depends: libcheese8
  Depends: libcolord2
  Depends: libcups2
  Depends: libdbus-glib-1-2
  Depends: libfcitx-config4
  Depends: libfcitx-gclient0
  Depends: libfcitx-utils0
  Depends: libfontconfig1
  Depends: libgdk-pixbuf2.0-0
  Depends: libgeonames0
 |Depends: libgl1-mesa-glx
  Depends: <libgl1>
  Depends: libglib2.0-0
  Depends: libgnome-desktop-3-12
  Depends: libgnome-menu-3-0
  Depends: libgtk-3-0
  Depends: libgtop-2.0-10
  Depends: libibus-1.0-5
  Depends: libkrb5-3
  Depends: libnm-glib4
  Depends: libnm-gtk0
  Depends: libnm-util2
  Depends: libnotify4
  Depends: libpango-1.0-0
  Depends: libpangocairo-1.0-0
  Depends: libpolkit-gobject-1-0
  Depends: libpulse-mainloop-glib0
  Depends: libpulse0
  Depends: libpwquality1
  Depends: libtimezonemap1
  Depends: libunity-control-center1
  Depends: libunity-settings-daemon1
  Depends: libupower-glib3
  Depends: libwacom2
  Depends: libwebkit2gtk-4.0-37
  Depends: libx11-6
  Depends: libxi6
  Depends: libxml2
  Depends: accountsservice
  Depends: apg
  Depends: desktop-file-utils
  Depends: gkbd-capplet
  Depends: gnome-desktop3-data
  Depends: adwaita-icon-theme
  Depends: gnome-menus
  Depends: unity-settings-daemon
  Depends: gnome-settings-daemon-schemas
  Depends: gsettings-desktop-schemas
  Depends: gsettings-ubuntu-schemas
  Depends: ibus
  Depends: indicator-bluetooth
  Depends: indicator-datetime
  Depends: indicator-keyboard
  Depends: indicator-power
  Depends: indicator-sound
  Conflicts: gnome-control-center
  Conflicts: <gnome-control-center-unity>
  Conflicts: <unity-control-center-datetime>
  Damaged: compiz
  Damaged: gnome-bluetooth
  Damaged: gnome-power-manager
  Damaged: gnome-session
  Damaged: libglib2.0-0
  Damaged: metacity
  Damaged: unity
  Recommends: cups-pk-helper
  Recommends: gnome-session-bin
  Recommends: ubuntu-system-service
  Recommends: ibus
  Recommends: iso-codes
  Recommends: mousetweaks
  Recommends: policykit-1-gnome
  Recommends: libcanberra-pulse
  Recommends: system-config-printer-gnome
  Recommends: unity-control-center-faces
 |Suggests: gnome-screensaver
  Suggests: xscreensaver
 |Suggests: gnome-user-guide
  Suggests: ubuntu-docs
  Suggests: libcanberra-gtk-module
  Suggests: x11-xserver-utils
  Replaces: gnome-bluetooth
  Replaces: <gnome-control-center-unity>
  Replaces: <unity-control-center-datetime>

I have already tried

$ sudo apt-get --reinstall install compiz
$ sudo apt-get --reinstall install gnome-power-manager
$ sudo apt-get remove unity-control-center
$ sudo apt-get install unity-control-center
$ sudo apt-get remove gnome-control-center
$ sudo apt-get install gnome-control-center

none of which did affect any changes to the prompt above.

Previously, I had removed Firefox (is re-installed now) and I have already tried several graphics driver installations, because other similar issues let me believe that this was mainly an NVIDIA problem - but I am no more sure about this now. I did read many related issues, none of which has set me on the solution track.

How can I repair the control center?

EDIT 1: I realized that, after setting NoDisplay=false in /etc/xdg/autostart/indicator-power.desktop, the battery icon appears at startup, before I'm being logged in. So, it's generally available in my system installation, but my user configuration seems to stop it.

EDIT 2: I'm using snap. $ snap list shows:

Name  Version    Rev   Tracking  Publisher   Notes
core  16-2.35.4  5662  stable    canonical✓  core
vlc   3.0.4      555   stable    videolan✓   -

EDIT 3: All system applications, the Control Center, the Battery Icon and also Rhythmbox show the following line in the Ubuntu exception window:

Title: ... crashed with signal 7 in gst_update_registry()

So, I'm currently searching the issue in the field of GStreamer - which I do not know up to now - any hint is welcome. Thanks.

EDIT 4: Meanwhile, I've uninstalled and re-installed GStreamer:

$ sudo apt-get purge gstreamer1.0-tools
$ sudo apt-get purge libgstreamer1.0-0
$ sudo apt-get install libgstreamer1.0-0
$ sudo apt-get install gstreamer1.0-tools
$ sudo apt install gstreamer1.0-plugins-good
$ sudo apt install gstreamer1.0-plugins-base
$ sudo apt autoremove

It seems to me my Ubuntu acts quicker since, but there's no visible effect on the availability of the system applications that I am still missing.


As there is not yet a direct solution to this issue, I helped myself with the following workaround. Like I had mentioned in EDIT 1 of the question, I've observed that the battery icon is displayed at startup before being logged in. It is also displayed when being logged in as a guest.

Given that, the issue is obviously related to my existing user account. Therefore, I've created a new user account according to these adduser instructions and I've moved all my personal documents there, leaving the account settings untouched.

Up to now, everything works fine. I'm going to document here, if any subsequent issues or insights occur.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.