It is hard to describe my problem when so many issues are involved, so let me start with the issue I need help with first. Links to pre-existing posts are MOST welcome.

A SATA internal hard drive, used only for data (music, docs, etc) and never for booting, now shows as Unallocated for the entire drive. It was originally formatted as EXT4, single partition (sba4) (Toshiba). Question At Hand: Is this a "data recovery" issue or a partition issue? And then, how do I proceed?

Q: What was the last thing you did on it? A: I ran some Boot Manager programs (Boot Repair, etc) to fix sba1 and may have pointed it at this drive by accident.

Q: Why Boot Manager? A: Trying to fix an Ubuntu 18.04 boot from sba1 on a separate hard drive (Seagate).

Q: Fix what? A: FSCK reported 4 bad sectors, and it may be that I had a bad sector or such in the MBR. Now, it fails to boot normally AND in recovery. Running fsck -vcck all night did not help, and caused the original GRUB to vanish. Boot Repair Disk created a new GRUB that did not help either.

Q: How urgent is the issue with the sba4 Toshiba? A: I was hoping to use it to repair the sba1 Seagate by copying the Home directory there. If I tried to copy to sba4, I would need to format first, and thus lose all the data. That is why I don't want to try to do anything more on the non-booting Ubuntu until I fix the unallocated data disk.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.