0

I had upgraded my Ubuntu 16.04 to Ubuntu 18.04. The upgrade completed and the system tried rebooting, but after that my PC no longer boots. I get a black screen, with no disk activity. If I press the power button my PC turns off immediately (no need for long press). I tried Boot-Repair but the process completes with errors. I think the last one is the most relevant.

http://paste.ubuntu.com/p/XFvWjsGCxz/

  • If by errors you mean the first two comments then no, not a problem. You have a UEFI system, Ubuntu installed in the same mode, a EFI partition as required. You aren't supposed to have a bootloader installed in the MBR. First thing to check is the boot order in UEFI and making sure "ubuntu" is still selected. If you find more than one entry saying "ubuntu", try the others just in case. If this doesn't solve it then something very wrong happened with the version upgrade. – GabrielaGarcia Oct 12 '18 at 19:12
0

I fixed it by disabling SecureBoot from UEFI. I don't know why after the update this had become a problem (since with Ubuntu 16.04 SecureBoot has always remained activated) and currently I do not have too much time to investigate.

In any case, thanks to GabrielaGarcia for the clarifications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.