I have Ubuntu 18.04 Dual booting with Windows 10 on my HP-EliteBook-745-G2, and for some reason, I cannot seem to find WiFi networks through my WiFi adapter, but Ethernet works (however, Ethernet stops working properly if I shut my screen down, and go back into my laptop, forcing me to restart my laptop to use Ethernet).

What I have done that didn't work:

  • Uninstalled Kernels and reinstalled.

  • Tried using rtlwifi.new as a fix.

  • Tried connecting through a hidden network, with different networks in different places.

  • Reinstalled Ubuntu.

  • sudo service network-manager restart

So I thought I would create a new post to get a different perspective here.

Side note: WiFi works perfectly on the Windows side of things, these problems persist only on my Ubuntu boot.

The output of lshw -C network gives:

$ sudo lshw -C network
[sudo] password for nathan: 
  *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0f0
       version: 0e
       serial: 30:8d:99:bf:09:ab
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=10.0.0.167 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:39 ioport:4000(size=256) memory:d5804000-d5804fff memory:d5800000-d5803fff
  *-network
       description: Wireless interface
       product: BCM4352 802.11ac Wireless Network Adapter
       vendor: Broadcom Limited
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlo1
       version: 03
       serial: 28:c2:dd:8f:85:ec
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:38 memory:d0a00000-d0a07fff memory:d0800000-d09fffff

Edit: Just for the people using edits to correct my grammar, 'I'd' is the same as 'I would'.

Another edit: Ran rfkill list all and here's the results:

    $ rfkill list all
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Then ran : dmesg | grep wl to produce:

$ dmesg | grep wl
[    0.000000] DMI: Hewlett-Packard HP EliteBook 745 G2/221C, BIOS M84 Ver. 01.07 03/10/2015
[    6.918774] wl: loading out-of-tree module taints kernel.
[    6.918782] wl: module license 'MIXED/Proprietary' taints kernel.
[    6.951608] wl: module verification failed: signature and/or required key missing - tainting kernel
[    7.123725] wlan0: Broadcom BCM43b1 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)
[    7.330784] wl 0000:02:00.0 wlo1: renamed from wlan0
[   10.672629] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[   10.791775] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready

Full diagnostics

 $ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)

Edit again

    :~$ sudo modprobe wl && dmesg | grep wl
[    0.000000] DMI: Hewlett-Packard HP EliteBook 745 G2/221C, BIOS M84 Ver. 01.07 03/10/2015
[    7.004949] wl: loading out-of-tree module taints kernel.
[    7.004958] wl: module license 'MIXED/Proprietary' taints kernel.
[    7.011342] wl: module verification failed: signature and/or required key missing - tainting kernel
[    7.888998] wlan0: Broadcom BCM43b1 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)
[    7.923740] wl 0000:02:00.0 wlo1: renamed from wlan0
[   11.818773] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[   11.937130] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[ 2546.180968] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[ 2546.291784] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready

I had several times problems with Ubuntu 16.04 and restart of network manager always solved the issue.

So please try

sudo service network-manager restart
  • I should have included this in my post, this was another thing that I had attempted to begin with, didn't solve anything :c – Nathaniel Miller Oct 12 at 15:18

This will be a partial answer until we track down the exact issue. I will edit the answer to provide further steps as we progress.

First, the conf file for a Realtek driver isn't needed; please remove it:

sudo rm /etc/modprobe.d/rtl8723de.conf

Second, your /etc/network/interfaces file is faulty. Please amend it:

sudo nano /etc/network/interfaces

Amend the file to read:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Save (Ctrl+o followed by Enter) and exit (Ctrl+x) the text editor.

Reboot and tell us if there is any improvement.

EDIT: We notice this error in your paste:

ERROR @wl_dev_intvar_get :

A search reveals many complaints involving your exact 14e4:43b1 device and only one solution: https://forums.linuxmint.com/viewtopic.php?f=53&t=236084&start=20

I suggest that you try the same:

sudo apt purge bcmwl-kernel-source
sudo apt install broadcom-sta-dkms

Reboot and show us:

dmesg | grep wl
  • So far no improvement. – Nathaniel Miller Oct 12 at 16:15
  • May we see: sudo dpkg -s bcmwl-kernel-source | grep Version We hope it is 6.30.223.271+bdcom-0ubuntu4. – chili555 Oct 12 at 16:23
  • I can confirm it is: 6.30.223.271+bdcom-0ubuntu4 – Nathaniel Miller Oct 12 at 17:02
  • I have just seen this edit now. Did broadcom install steps, but didn't fix the issue. 'dmesg | grep w1' shows the same as it did before except '[ 10.585199] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready' repeats 8 times. – Nathaniel Miller Oct 22 at 14:46
  • I hope you meant: dmesg | grep wl not w1. wL not w-one Do you confirm that the ERROR @wl_dev_intvar_get : is still present? – chili555 Oct 22 at 14:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.