I can mount my SMB share using nautilus by simply adding the location smb://ip

Here's what happens when I use smbclient on another computer:

lz@air:/media$ smbclient -L //192.168.0.3
WARNING: The "syslog" option is deprecated
Enter WORKGROUP\lz's password: 
OS=[Windows 6.1] Server=[Samba 4.5.12-Debian]

    Sharename       Type      Comment
    ---------       ----      -------
    Public          Disk      
    IPC$            IPC       IPC Service (Samba 4.5.12-Debian)
Connection to 192.168.0.3 failed (Error NT_STATUS_CONNECTION_REFUSED)
NetBIOS over TCP disabled -- no workgroup available

Here's locally, to localhost:

pi@raspberrypi:~ $ smbclient -L localhost
WARNING: The "syslog" option is deprecated
Enter pi's password: 
Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.5.12-Debian]

    Sharename       Type      Comment
    ---------       ----      -------
    Public          Disk      
    IPC$            IPC       IPC Service (Samba 4.5.12-Debian)
Connection to localhost failed (Error NT_STATUS_CONNECTION_DISCONNECTED)
NetBIOS over TCP disabled -- no workgroup available

Here's my SAMBA configuration:

RUN echo '[global]\n\
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536\n\
smb ports = 445\n\
max protocol = SMB2\n\
min receivefile size = 16384\n\
deadtime = 30\n\
os level = 20\n\
map to guest = bad user\n\
printer = bsd\n\
printcap name = /dev/null\n\
load printers = no\n\
create mask = 0644\n\
force create mode = 0644\n\
directory mask = 0755\n\
force directory mode = 0755\n\
browsable = yes\n\
writable = yes\n\
guest account = root\n\
force user = root\n\
force group = root\n\
[Public]\n\
path = /data/share\n\
guest ok = yes\n\
read only = no' > /etc/samba/smb.conf

It's worth mentioning that there's no password on my samba

UPDATE:

After doing what told in the comment below, I have

lz@air:~$ smbclient -L //192.168.0.3
WARNING: The "syslog" option is deprecated
Enter WORKGROUP\lz's password: 
OS=[Windows 6.1] Server=[Samba 4.5.12-Debian]

    Sharename       Type      Comment
    ---------       ----      -------
    Public          Disk      
    IPC$            IPC       IPC Service (Samba 4.5.12-Debian)
OS=[Windows 6.1] Server=[Samba 4.5.12-Debian]

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------
    WORKGROUP

SHouldn't I see my folders? How should I mount this?

up vote 1 down vote accepted
+50

[1] Edit /etc/samba/smb.conf

[2] Place a # sign in front of smb ports = 445 so that it looks like this:

#smb ports = 445

This will make it to samba does not read that line and it will default to using ports 445 and 139.

[3] Restart the smbd service:

sudo service smbd restart

SHouldn't I see my folders?

smbclient -L only lists the shares available on the server - and you have one named Public

How should I mount this?

smbclient //192.168.0.3/Public

You will end up at a command prompt: smb: \>

Enter ls to get a listing of the contents of Public and quit to close the connection.

  • it kinda worked. Can you take a look at my update? – Guerlando OCs Oct 14 at 13:09
  • I've edited my post to answer your questions – Morbius1 Oct 14 at 13:32

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.