0

This will look like a duplicate but I assure you it's not. Unless I simply haven't found the solution yet from the correct post.

When boot-repair says, "Please do not forget to make your BIOS boot on sda1/EFI/ubuntu/shimx64.efi file!", how do I do this?

I would think that there should be NO difference between rebooting and turning off and then back on your computer. But in my case, there is.

Update: Now both restarting and turning off/on do not boot

I looked here: How do I make my BIOS boot on shimx64.efi file? (AND MANY OTHER SOURCES BUT TO NO AVAIL)

I tried, this: - as the previous post suggests. Update: along with reading the links that oldfred posted

ubuntu@ubuntu:~$ sudo efibootmgr -v

0001 shows that it points to my file. If I restart the computer, it boots (but very slowly), and it seems to be ok as long as I only restart (BUT if I turn off my computer, it will not boot and I am forced to use the USB live ubuntu install, and repeat the boot-repair install process. This is getting incredibly time consuming. Does anyone know how to force the system to always use this? I'm using the LVM setup on ubuntu install. And I believe i'm using EFI since the file is shimx64-efi.

Output from: (using live USB) ubuntu@ubuntu:~$ sudo efibootmgr -v

BootCurrent: 0008
Timeout: 0 seconds
BootOrder: 0001,0008,0006,0005,0000,0003,0004
Boot0000* Windows Boot Manager  VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0001* ubuntu    HD(1,GPT,f3e3baf6-59ba-457d-8dab-9b9770eace6e,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0003  UEFI: IP4 Realtek PCIe GBE Family Controller  PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(2089840f7458,0)/IPv4(0.0.0.00.0.0.0,0,0)AMBO
Boot0004  UEFI: IP6 Realtek PCIe GBE Family Controller  PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(2089840f7458,0)/IPv6([::]:[::]:,0,0)AMBO
Boot0005* Hard Drive    BBS(HD,,0x0)AMGOAMNO........o.S.T.1.0.0.0.L.M.0.2.4. .H.N.-.M.1.0.1.M.B.B....................A...........................>..Gd-.;.A..MQ..L.2.S.Q.R.9.J.C.F.0.A.5.0.6.6. . . . . . ......AMBOAMNO........u.K.i.n.g.s.t.o.n.D.T. .1.0.1. .G.2. .P.M.A.P....................A.............................B..Gd-.;.A..MQ..L.K.i.n.g.s.t.o.n.D.T. .1.0.1. .G.2. .P.M.A.P......AMBO
Boot0006* CD/DVD Drive  BBS(CDROM,,0x0)AMGOAMNO........o.T.S.S.T.c.o.r.p. .C.D.D.V.D.W. .S.N.-.2.0.8.B.B....................A...........................>..Gd-.;.A..MQ..L.8.R.9.F.G.6.C.E.0.9.D.0.Z.X. . . . . . ......AMBO
Boot0007  Could not parse device path: No such file or directory

I am about to restart my computer again (after reinstalling boot-repair, for the nth time), and am definitely not looking forward to repeating this process again. The reason for my post.

Update: Still did not reboot, created the following postbin: paste.ubuntu.com/p/PF3f4xNDjT On reboot, if I hit ESC at the splash screen, I get the following menu: menu of which none of these options work - they all just bring me straight back to this menu. And not one is this one which boot-repair said I need to boot to: sda1/EFI/ubuntu/shimx64.efi If I try 'other' and boot to rescue mode, it brings me to this prompt and stops: initramfs prompt As of 10/11/2018 10:10PM EST - I'm stuck

Thank you! I really appreciate any guidance here. This is driving me absolutely nuts!

9
  • What brand/model system? May be best to see details, use ppa version with your live installer or any working install, not older Boot-Repair ISO: Just run the summary report, the auto fix sometimes can create more issues. help.ubuntu.com/community/Boot-Repair – oldfred Oct 11 '18 at 20:59
  • Now it doesn't even restart - I'm back online only with the USB live drive. I have a samsung NP350E7C-A01US Specs here: samsung.com/us/computer/laptops/NP350E7C-A01US-specs I'm using the PPA for the boot-repair. Also, this was a windows machine that had secure boot enabled. I formatted the drive. Disabled secure boot. Running in UEFI mode. Booting EFI, grub shows I'm using EFI. – darga33 Oct 11 '18 at 23:31
  • Older Samsung threads: Phoenix SecureCore Tiano bios setup and secure boot is greyed out. You need to set a Supervisor Password in the Security tab Samsung w/ Phoenix Tiano SecureCore askubuntu.com/questions/760102/… Samsung Ativ Book 9 Plus UEFI Install - manual copy of grub to /EFI/Boot ubuntuforums.org/showthread.php?t=2230919 Samsung ATIV Book 9 Plus ubuntuforums.org/showthread.php?t=2203824 Update UEFI/BIOS helped see ports and other issues. Samsung 900X3E ubuntuforums.org/showthread.php?t=2176559 – oldfred Oct 11 '18 at 23:34
  • Here is my pastebin url: (just ran now) paste.ubuntu.com/p/2vWZzH3CX6 – darga33 Oct 11 '18 at 23:37
  • I checked those links that you posted. They are great links and I even followed some things during install. I'm guessing that I did the installation wrong. But what I do not understand is that why after I install, I simply can not reboot. I am going to try installing again but this time just do the non LVM simple install. I think I was trying to be more complicated than need be. Unless I'm missing something? Maybe my pastebin might show the cure all fix is real simple and I Just don't understand it. – darga33 Oct 11 '18 at 23:51
0

Ok so after much searching I found out that if you try and install ubuntu and it works, but then when you shut down your computer, you can not boot, it may be because 1. You never installed an EFI partition (if you have a EFI system). or 2. During the installation wizard, you didn't select the location of your EFI partition (to be the location to install your boot loader files).

Once I did that it finally worked. Hopefully this helps someone out there!

0

But what I do not understand is that why after I install, I simply can not reboot?

Have you tried to enter the bios menu? press f2 to enter the bios menu. if you have placed the os partition with f5 / f6 by placing the os you chose in the topmost place.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.