1

I installed Ubuntu on my new laptop, quite a challenge as I am not well versed in computing. It seems to be working fine, except the inbuilt microphone is not working. Not too sure what to do about it, am I missing a driver? Here is the screen grab from alsamixer:

enter image description here

I do not see a microphone

Thanks for your help,
Marc

1

Press F4 key to see the Capture/Input controls. But you probably won't see them. Not yet.

Remember those "HDA Intel" and "ALC256". They will be important in your quest for answers. You are not alone, check this: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1793410 This last post resumes it all: https://forums.linuxmint.com/viewtopic.php?f=49&t=279424&start=47 Check preceding posts above for more details...

This kind of problem is usually solved by adding an option line at the end of /etc/modprobe.d/alsa-base.conf file. You will need to restart your computer to see the result. You could try adding options snd-hda-intel model=headset-mic at the end of /etc/modprobe.d/alsa-base.conf file. Or something else. There are lots of things to be tried with this file. Restart your computer for each test. You need to open the file as administrator to be able to make changes. Check my tutorial for more details: Asus Eee Pc X101ch and Intel Atom: Fix The Speaker And Microphone! You probably won't find the exact answer there but you can follow the method...

Did you find the right answer? Please share with us! But seemingly... there is no solution yet. Bonne chance!

0

This bug has been addressed here: https://bugzilla.kernel.org/show_bug.cgi?id=201251

The safe workaround for now is by changing the model of your snd-hda-intel to dell-headset-multi. But with this workaround, your notebook internal microphone is still unusable, only external microphone works.

  1. Open /etc/modprobe.d/alsa-base.conf with your favorite editor with sudo privilege
  2. Add options snd-hda-intel model=dell-headset-multi in the bottom
  3. Save
  4. If you want quick apply, execute sudo alsa force-reload, otherwise, reboot your notebook
  5. insert your headset (headphone with microphone) to the audio slot, then audio mode selection popup will show, select Headset mode (an icon with headphone and microphone)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.