2

I want to configure fcitx (sogou-pinyin) input method on Kubuntu 18.04. First I configured basic keyboard layouts. Shortcut for switching layout is Caps Lock.

keyboard hardware & layout settings

After that, I installed fcitx and configured input methods. Switching shortcut is Ctrl+Shift, i.e. Caps Lock switches En/Ru, Ctrl+Shift switches En/Ch.

input method config

input method shortcuts

The problem is that fcitx always watches keyboard input. When fcitx is running, switching layouts and input methods (both with Caps Lock and Ctrl+Shift) is possible only when some text area controls (not just window) has focus. So that when I try to switch keyboard layout and/or input method in an applications such as web browser, I cannot do so.

So, I need solve this one of two ways, but I don't know how to realize.

  1. Allow fcitx to switch input method independently of what control has focus;
  2. Add a third keyboard layout - Chinese. Fcitx is activated only when Chinese keyboard layout is selected.

Any ideas?

0

Go to the Addon Config of the Input Method settings, select Show Advanced Options. Then find the X Keyboard Integration, and press the Settings button on the right of the corresponding line. On the popup window unselect the first line: "Allow to rewrite system XKB setup" (or something line this: I look the Russian version). Confirm changes, restart Fcitx. Finally start XKB setting, change something forth and back, and confirm changes (it is necessary to remove all changes in the XKB configuration made by Fcitx). That is all.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.