After I updated from 16.04 to 18.04 my dual screen setup has stopped working.

I have two monitors, one connected from hdmi and one connected from vga.

Both are connected straight from the motherboard(no dedicated gpu).

The hdmi one works fine but the vga one doesn't show any video. I can move my mouse over to where it should be so ubuntu recognises it but it still doesn't show any output.

hdmis resolution is 1920x1080 and vgas set resolution is 1280x1024 (worked fine on ubuntu 16.04)

other solutions suggested copying ~./config/monitors.xml but no such file exists.

I'm using xfce with lightdm as a login manager

output of xrandr is

    Screen 0: minimum 320 x 200, current 3200 x 1080, maximum 8192 x 8192
VGA-0 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 340mm x 270mm
   1280x1024     60.02*+  75.02  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32  
   640x480       75.00    72.81    59.94  
   720x400       70.08  
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+  59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  

output of sudo lshw -c video

 *-display                 
       description: VGA compatible controller
       product: BeaverCreek [Radeon HD 6550D]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 1
       bus info: pci@0000:00:01.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:37 memory:c0000000-cfffffff ioport:f000(size=256) memory:fef00000-fef3ffff memory:c0000-dffff

Any help would be great thank you

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.