1

The national keyboard layout of my computer is in French. I added in the settings language and region another layout (or "input source") which is English (US).

When I switch to that US layout, the typing is US for all apps, however, the shortcut layout stays French in some apps (at least Pycharm and imageJ).

I do not know if it can be of any help, the keyboard input method system is ibus, and the input method config is:

The current configuration for the input method:
* Active configuration: ibus (normally missing)
* Normal automatic choice: ibus (normally ibus or fcitx or uim)
* Override rule:
* Current override choice: (en_GB)
* Current automatic choice: ibus
* Number of valid choices: 3 (normally 1) The override rule is defined in /etc/default/im-config. The configuration set by im-config is activated by re-starting X. Explicit selection is not required to enable the automatic configuration, if the active one is default/auto/cjkv/missing. Available input methods: ibus maliit xim Unless you really need them all, please make sure to install only one input method tool.

  • Does it have anything to do with "national/native" layout as your question suggests? As per your answer it seems Pycharm and imageJ detects only the first keyboard layout. Once you push "English (US)" to the first place as per your answer, are you able to switch to French layout in Pycharm and imageJ? – pomsky Oct 12 '18 at 13:11
  • 1
    Yeah, that's my whole point, the issue is with multiple layouts and that some apps detect only the first layout. That's why "national layout" is somewhat misleading, you can set multiple layouts of the same language (say English) if you wish. – pomsky Nov 13 '18 at 15:54
  • Once you push "English (US)" to the first place, the keyboard layout linked to shortcut will be English (US), it cannot be changed inside the software. Though the typing keyboard layout can be different, but still needs to be set up globally. For the national layout link to the problem I encountered, I think it is highly linked to it as the problem arise when you have multiple keyboard layout, and this is highly correlated with one not being an English speaker. Moreover, when I looked for an solution to my problem, I looked for an answer this way. – TifTaf Nov 13 '18 at 16:00
1

In the settings, tab Language and Region, the list of the input sources, English(US) needs to be in the first place.

settings languages re-odering

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.