Throughout all this process connection to the Internet was working properly.

Every time I turned on my computer an error message popped saying "System program problem detected". I'm certain it is about this issue. Also noted: the OS is Ubuntu 18.04.

First, it did not update anything while using the clicking method (through GUI). Software Updater appeared, showed the updates and then I clicked "Install Now" but began the process and when arriving some of the first steps, it disappears.

For this problem I tried updating and upgrading manually using the terminal (sudo apt-get update && sudo apt-get upgrade). This solved part of the problem as most of the packages got to be updated.

Nonetheless, the problem persists as Ubuntu base (security updates) and Unused kernel updates to be removed keep appearing with the same problem happening after hitting the "Install Now" button. I tried again with the terminal and the problem prevails along with the "System program problem detected" message.

Failed solutions:

a) I thought that Internet connection was the origin of the problem but I uninstalled Wicd and reinstalled it. b) I tried: sudo rm -rvf /var/lib/apt/lists/* and then sudo apt-get update, as this answer to another post says.

What can I do? Thanks.

Output for sudo apt-get update:

Hit:1 http://es.archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://archive.canonical.com bionic InRelease
Get:3 http://es.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]                         
Get:4 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]                          
Get:5 http://es.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]                   
Fetched 247 kB in 1s (337 kB/s)                                                                  
Reading package lists... Done

Output for sudo apt-get upgrade:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 libjavascriptcoregtk-4.0-18 libwebkit2gtk-4.0-37 linux-generic linux-headers-generic
  linux-image-generic
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
  • I would suggest copy/pasting the errors (or whole output) for your sudo apt-get update or upgrade to your question, so we can see the error which is the best clue for fixing your issue. Currently your 'problem' is undefined except to you as only you can see it. – guiverc Oct 11 at 11:30
up vote 0 down vote accepted

Firstly, update the following:

sudo apt autoremove && sudo apt autoclean -y

then open nano by sudo nano /etc/apt/sources.list and check for any mismatches of default ubuntu update repo's:

Note -

16.04 - Xenial

18.04 - Bionic

deb http://in.archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse
deb http://in.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe multiverse
deb http://in.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu bionic-security main restricted universe multiverse

deb-src http://in.archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted universe multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe multiverse

If its easier then, delete the lines by pressing 'CTRL + K' in nano. and copy-paste them with the ones provided above to you.

Press 'CTRL + X', to exit. Prompts to save - Press 'Y' to save.

Type cat /etc/apt/sources.list to double-check if they are correct.

Then do a sudo apt update && sudo apt upgrade -y Hopefully should have fixed your issues after this.

  • I am reading the sources.list file and I am thinking that the problem may come from that I upgraded the OS version from 16.04 to 18.04. I come to this conclusion because I find lines about "xenial", which I am certain refers to the 16.04 version. Should I copy-paste it? – HyHyHyena Oct 11 at 12:04
  • Yes your right, if its xenial then its 16.04 version's repo's. Change them to bionic and see if it works? or simply copy paste them into your sources.list which i mentioned above. Good luck! – Shaze Oct 11 at 12:13
  • 1
    It totally worked! I am very grateful for I shall not be afraid of security issues! – HyHyHyena Oct 11 at 12:26
  • I'm glad it all worked fine for you ;) – Shaze Oct 11 at 12:32
  • The first command results in E: Unable to locate package autoclean. Your command sudo apt install autoclean is wrong, I think you meant sudo apt autoclean. – mook765 Oct 11 at 12:33

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.