5

I am new in this kind of environment and I want to learn this. This is started once I install VirtualBox-5.2.18-124319-Win and successfully installing ubuntu-18.04.1-live-server-amd64 in that virtual machine, however in the instruction command me to install VBoxguestaddition, and I get this kind of error, eventhough I have 2 installations of VBoxguestaddition and VBoxGuestAdditions_4.3.20 in .iso;

Could not mount the media/drive 'C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso' (VERR_PDM_MEDIA_LOCKED).


Result Code: 
E_FAIL (0x80004005)
Component: 
ConsoleWrap
Interface: 
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}
Callee: 
IMachine {85cd948e-a71f-4289-281e-0ca7ad48cd89}

I tried use sudo command in terminal sudo mount /dev/cdrom/media/cdrom and not succeed, I ask my friend and lecturer but no one give a proper advice. Thank you in advance. screen shoot

1
5

Fooling around with this problem, I clicked on Devices>Optical Drives and unchecked VBoxGuestAdditions.iso.

I then got a question asking: Would you like to try to force ejection of this disk? I clicked the [Force Unmount] box.

Next, go back to Devices>Optical Drives and add a check tp the VBoxGuestAdditions.iso

At least I'm no longer getting an error. Hope this works for you

1
2

I went to

Devices -> Optical Drives

and selected "Remove Disk From Virtual Drive". Then "Force Unmount".
Then I was able to select

Devices -> Install Guest Additions CD Image...

1

I just started using Ubuntu and came across this problem. When you get this error, it will show that the file(with its path) could not be loaded. You have a good look at it and maybe write it down somewhere.Now, you should look at the bottom right of your virtual machine window, you will see a CD Icon thingy. Right click on it and select "Choose a disk file". Click there and navigate with that path to the iso file. Click on it and a window will pop up, select 'Force Unmount'(weird thing the file infact loads). Now, right click on CD Icon again and you should see VBox something something.iso , click on it and a window will popup in Ubuntu, click run and enter your password. Done

0

If you are getting the error This system is currently not set up to build kernel modules open the terminal and enter sudo apt-get install gcc perl make. Then reboot, right click the guest addition cd and unmount it, and then re-insert it from Devices in menu.

0

This in the VirtualBox, is a bit of pain always. However, for me, it worked like this:

Under devices, unmount & remount the Guest ISO. For me a window opened where all the necessary Tetris packages were now included. They weren't included in the VM folder. I went to the folder on the system (Parrot in this case) and just run the autoinstal.sh with sudo ./autoinstal.sh. It installed now smoothly and now the full screen is working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.