6

Just build my own computer and installed ubuntu 16.04. But I can't seem to get my wifi usb adapter working. It's an iptimeA3000UA. Although the packaging said it only works for windows, I thought it would be fine.

Here's my wireless info script as suggested I should add:

$ lsusb gives me:

ID 0bda:b812 Realtek Semiconductor Corp.

I downloaded the original windows drivers and used ndiswrapper (https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper). I installed it properly and it also gives "hardware present: yes", but still no wifi.

$ ndiswrapper -L gives me:

netrtwlanu : driver installed
device (0BDA:B812) present

So on this site I found that mine is 8812bu iguess: https://wikidevi.com/wiki/Realtek_RTL8812BU_USB_Module:

"0bda:b812 Realtek RTL8812BU Wireless 802.11ac 2x2 USB 3.0 NIC"

So I tried to install drivers for RTL8822BU (works for 8812 too I guess) off of github https://github.com/ulli-kroll/rtl8822bu, but still no luck.

I am doing something wrong, or does my device simply not work?

7

Found the solution:

https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.2.4.4_26334.20180126_COEX20171012-5044

did as instructed and works like a charm!! :D

1
2

I have a solution for Ubuntu 16.04 LTS, with a Techkey-6B06, which uses an RTL8812BU chipset.

  1. git clone https://github.com/cilynx/rtl88x2bu

  2. modify build.sh: It's missing sudo in front of each dkms command.

  3. chmod +x build.sh

  4. ./build.sh

Then just configure your wifi settings in Ubuntu as normal.

2
  • This worked for me on Linux MX. If you don't have internet on the computer that is needing wifi, download the code on to a USB key and then plug it in on the other computer: github.com/cilynx/rtl88x2bu/archive/…
    – Eyal
    Dec 24 '20 at 8:14
  • The answer provided by AlbertY also worked on Linux Mint 20.2 (Uma) with the Maxesla Mini WiFi Adapter 1200M 802.11ac Dual Band 2.4/5GHz AC1200 Wireless Network Adapter. The repo code has changed slightly but the steps are basically the same: 1. git clone https://github.com/cilynx/rtl88x2bu 2. cd rtl88x2bu 3. sudo ./deploy.sh 4. Reboot machine
    – Glaze
    Sep 12 at 15:23
0

Eyal's answer worked on my Ubuntu 18.04 desktop with kernel 4.15. I bought the Techkey Wireless USB WiFi Adapter, 1200Mbps Dual Band 2.42GHz/300Mbps 5.8GHz/867Mbps High Gain Dual 5dBi Antennas Network WiFi USB 3.0 for Desktop Laptop with Windows 10/8/7/XP, Mac OS/10.4-10.15.

Steps are as follows:

  1. Download https://github.com/cilynx/rtl88x2bu/archive/5.6.1_30362.20181109_COEX20180928-6a6a.zip
  2. cd path/to/rtl88x2bu-5.6.1_30362.20181109_COEX20180928-6a6a
  3. sudo chmod +x build.sh
  4. bash build.sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.