Having an issue with settings after updating today. I've tried to launch from terminal, but I just get bus error (core dumped). Also tried

sudo apt remove gnome-control-center
sudo autoremove
sudo apt install gnome-control-center

Still no luck if anyone has any tips it'd be much appreciated!


In Ubuntu 18.04 with NVIDIA graphics I had to install proprietary nvidia-driver-430.40 to make the System Settings "gnome-control-center" work.

and added repositories:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo add-apt-repository ppa:oibaf/graphics-drivers

and ran

sudo ubuntu-drivers autoinstall 

The problem was solved.

If does not work for you. To remove the PPAs run:

sudo ppa-purge ppa:graphics-drivers/ppa
sudo ppa-purge ppa:oibaf/graphics-drivers

Modified from here.

  • 1
    Thanks that was exactly what I needed to make my settings work. interestingly. – Jasper Lankhorst May 13 '20 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.