0

I updated my ubuntu 16.04 machine a few days ago to 18.04. I had a few issues upgrading but I've delt with those. only one issue remain: no GUI. I've spent days troubleshooting and googling the issue but none of the fixes that i've found have fixed the issue. I'm not even sure what the root issue is.

anyway. Lightdm failes to start and I've tried changing to gdm3 but it also crashes. I have reinstalled them both and reinstalled my intel graphical drives (xserver-xorg-video-intel)

the only problem that i can see in the syslog is

gpu-manager[6149]: Error: can't open /lib/modules/4.15.0-36-generic/updates/dkms

and

systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: lightdm.service: Failed with result 'exit-code'.
systemd[1]: lightdm.service: Triggering OnFailure= dependencies.
systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.

trying to restart lightdm (sudo service lightdm start) also fail.

Now, if I can't fix this issue. I do have a backup of my system but would it be possible to reinstall 18.04 completely without losing anything that is not system related?

I will provide the resul of any command below.

thank you for your help.

:EDIT1:

I've fixed it. kind of...

I looked into the /var/log/Xorg.0.log file and found this:

[    14.462] (WW) Falling back to old probe method for vesa
[    14.462] (II) modeset(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    14.462] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[    14.462] (==) modeset(0): RGB weight 888
[    14.462] (==) modeset(0): Default visual is TrueColor
[    14.462] (II) Loading sub module "glamoregl"
[    14.462] (II) LoadModule: "glamoregl"
[    14.462] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    14.464] (II) Module glamoregl: vendor="X.Org Foundation"
[    14.464]    compiled for 1.19.6, module version = 1.0.0
[    14.464]    ABI class: X.Org ANSI C Emulation, version 0.4
[    14.464] (II) glamor: OpenGL accelerated X.org driver based.
[    14.476] (EE)
[    14.476] (EE) Backtrace:
[    14.476] (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4d) [0x55d55f6cb8ad]
[    14.476] (EE) 1: /usr/lib/xorg/Xorg (0x55d55f513000+0x1bc649) [0x55d55f6cf649]
[    14.476] (EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f5e685e9000+0x12890) [0x7f5e685fb890]
[    14.476] (EE) 3: /lib/x86_64-linux-gnu/libc.so.6 (0x7f5e681f8000+0xb1646) [0x7f5e682a9646]
[    14.476] (EE) 4: /lib/x86_64-linux-gnu/libc.so.6 (__strdup+0xe) [0x7f5e682959ae]
[    14.476] (EE) 5: /usr/lib/x86_64-linux-gnu/libEGL_mesa.so.0 (0x7f5e61352000+0x211db) [0x7f5e613731db]
[    14.476] (EE) 6: /usr/lib/x86_64-linux-gnu/libEGL_mesa.so.0 (0x7f5e61352000+0x18d5d) [0x7f5e6136ad5d]
[    14.476] (EE) 7: /usr/lib/x86_64-linux-gnu/libEGL_mesa.so.0 (0x7f5e61352000+0x156be) [0x7f5e613676be]
[    14.476] (EE) 8: /usr/lib/x86_64-linux-gnu/libEGL_mesa.so.0 (0x7f5e61352000+0x15705) [0x7f5e61367705]
[    14.476] (EE) 9: /usr/lib/x86_64-linux-gnu/libEGL_mesa.so.0 (eglInitialize+0x138) [0x7f5e61361d28]
[    14.476] (EE) 10: /usr/lib/xorg/modules/libglamoregl.so (glamor_egl_init+0x10b) [0x7f5e63acfc9b]
[    14.476] (EE) 11: /usr/lib/xorg/modules/drivers/modesetting_drv.so (0x7f5e6430d000+0x9d89) [0x7f5e64316d89]
[    14.476] (EE) 12: /usr/lib/xorg/Xorg (InitOutput+0xc08) [0x55d55f5ac268]
[    14.476] (EE) 13: /usr/lib/xorg/Xorg (0x55d55f513000+0x56cd3) [0x55d55f569cd3]
[    14.476] (EE) 14: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xe7) [0x7f5e68219b97]
[    14.476] (EE) 15: /usr/lib/xorg/Xorg (_start+0x2a) [0x55d55f553b8a]
[    14.476] (EE)
[    14.476] (EE) Segmentation fault at address 0x0
[    14.476] (EE)
Fatal server error:
[    14.476] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    14.476] (EE)

I googled it and found a workaround here: Segmentation fault in XServer

so the login screen gets revealed propperly now, but I'm currently stuck in a login loop. but that is another issue.

ls -al /home/karl/.*author*
-rwx------ 1 karl karl 55770 okt 11 01:56 /home/karl/.ICEauthority
-rwx------ 1 karl karl  9570 dec  9  2017 /home/karl/.ICEauthority.backup.20171209
-rw------- 1 karl karl    54 okt 11 01:57 /home/karl/.Xauthority
-rw------- 1 karl karl    54 okt 11 00:16 /home/karl/.Xauthority.bak
-rw------- 1 karl karl    54 okt 11 01:06 /home/karl/.Xauthority.bakk
-rwx------ 1 karl karl    54 okt

8 02:36 /home/karl/.Xauthority.old

ls -al /var/lib/dkms
drwxr-xr-x  2 root root 4096 okt 11 02:06 .
drwxr-xr-x 86 root root 4096 okt 11 02:06 ..
-rw-r--r--  1 root root    6 aug 31  2016 dkms_dbversion

and

ls -al /usr/src
drwxr-xr-x 10 root root 4096 okt  5 14:40 .
drwxr-xr-x 11 root root 4096 feb 15  2017 ..
drwxr-xr-x 27 root root 4096 dec  4  2017 linux-headers-4.10.0-40
drwxr-xr-x  7 root root 4096 dec  4  2017 linux-headers-4.10.0-40-generic
drwxr-xr-x 27 root root 4096 okt  7 22:56 linux-headers-4.15.0-34
drwxr-xr-x  8 root root 4096 okt  7 22:56 linux-headers-4.15.0-34-generic
drwxr-xr-x 27 root root 4096 okt  7 22:57 linux-headers-4.15.0-36
drwxr-xr-x  8 root root 4096 okt  7 22:57 linux-headers-4.15.0-36-generic
drwxr-xr-x 27 root root 4096 feb 15  2017 linux-headers-4.8.0-36
drwxr-xr-x  7 root root 4096 feb 15  2017 linux-headers-4.8.0-36-generic

this is the error I get when trying to start a gnome shell.

sudo gnome-shell gnome
gnome-shell: symbol lookup error: /usr/lib/x86_64-linux-gnu/libmutter-2.so.0: undefined symbol: wl_global_get_interface

Trying to reinstall libmutter-2-0:

karl@Bulbasaur:~$ sudo apt install --reinstall libmutter-2-0
Läser paketlistor… Färdig
Bygger beroendeträd
Läser tillståndsinformation… Färdig
0 att uppgradera, 0 att nyinstallera, 1 att installera om, 0 att ta bort och 41 att inte uppgradera.
Behöver hämta 1 205 kB arkiv.
Efter denna åtgärd kommer ytterligare 0 B utrymme användas på disken.
Läs:1 http://se.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libmutter-2-0 amd64 3.28.3-2~ubuntu18.04.1 [1 205 kB]
Hämtade 1 205 kB på 0s (2 827 kB/s)
(Läser databasen ... 220135 filer och kataloger installerade.)
Förbereder att packa upp .../libmutter-2-0_3.28.3-2~ubuntu18.04.1_amd64.deb ...
Packar upp libmutter-2-0:amd64 (3.28.3-2~ubuntu18.04.1) över (3.28.3-2~ubuntu18.04.1) ...
Ställer in libmutter-2-0:amd64 (3.28.3-2~ubuntu18.04.1) ...
Hanterar utlösare för libc-bin (2.27-3ubuntu1) ...
/sbin/ldconfig.real: /lib/x86_64-linux-gnu/libSegFault.so is not a symbolic link

/sbin/ldconfig.real: /lib/x86_64-linux-gnu/libmemusage.so is not a symbolic link

/sbin/ldconfig.real: /lib/x86_64-linux-gnu/libpcprofile.so is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libplds4.so is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libnetapi.so.0 is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libmirclient.so.9 is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libnss3.so is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libnssutil3.so is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libplc4.so is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libssl3.so is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/librtmp.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libsmbconf.so.0 is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libminiupnpc.so.10 is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libnspr4.so is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libsmime3.so is not a symbolic link

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libmirprotobuf.so.3 is not a symbolic link

sudo ldconfig sudo] lösenord för karl: /sbin/ldconfig.real: /lib/x86_64-linux-gnu/libSegFault.so är inte en symbolisk länk

/sbin/ldconfig.real: /lib/x86_64-linux-gnu/libmemusage.so är inte en symbolisk länk

/sbin/ldconfig.real: /lib/x86_64-linux-gnu/libpcprofile.so är inte en symbolisk länk

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libplds4.so är inte en symbolisk länk

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libnetapi.so.0 är inte en symbolisk länk

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libmirclient.so.9 är inte en symbolisk länk

/sbin/ldconfig.real: /usr/lib/x86_64-linux-gnu/libnss3.so är in  GNU nano 2.9.3       /var/tmp/locale.XXf0eGrt

"är inte en symbolisk länk" means "is not a symbolic link"

  • Ubuntu 18.04 uses gdm (the gdm3 package) instead of lightdm. – user535733 Oct 10 '18 at 21:59
  • Is your an older computer? What video hardware do you have? I have an idea. – heynnema Oct 10 '18 at 23:18
  • @heynnema it's an i7 gen2. no gpu card. but I have fixed it, the issue now is the login loop. – Karl Blixt Oct 10 '18 at 23:19
  • What is the output of dkms status and ls -al /home/your_username/.*author*? Boot into recovery mode if you have to. – heynnema Oct 11 '18 at 0:03
  • @heynnema I didn't have dkms installed and once i installed the package the command gave no output. and yes everything in my home folder is owned by me and is in my group, I've ran sudo chmod username:username -R . – Karl Blixt Oct 11 '18 at 0:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.