2

I'm trying to install rainlendar-lite on ubuntu 18.04.1 and keep getting

Download is performed unsandboxed as root as file '/home/jim/Downloads/rainlendar2-lite_2.14.2.b157-1_amd64.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

jim@jim-Z1-7623:~/Downloads$ sudo apt-get install ./rainlendar2-lite_2.14.2.b157-1_amd64.deb
[sudo] password for jim: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'rainlendar2-lite' instead of './rainlendar2-lite_2.14.2.b157-1_amd64.deb'
The following NEW packages will be installed:
  rainlendar2-lite
0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
Need to get 0 B/17.9 MB of archives.
After this operation, 20.5 MB of additional disk space will be used.
Get:1 /home/jim/Downloads/rainlendar2-lite_2.14.2.b157-1_amd64.deb rainlendar2-lite amd64 2.14.2.b157-1 [17.9 MB]
Selecting previously unselected package rainlendar2-lite.
(Reading database ... 180109 files and directories currently installed.)
Preparing to unpack .../rainlendar2-lite_2.14.2.b157-1_amd64.deb ...
Unpacking rainlendar2-lite (2.14.2.b157-1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Setting up rainlendar2-lite (2.14.2.b157-1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
N: Download is performed unsandboxed as root as file '/home/jim/Downloads/rainlendar2-lite_2.14.2.b157-1_amd64.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

EDIT: Thanks everyone. I've given up on installing rainlendar 2.14, and gone back to rainlendar 2.13, which works fine. In checking on the rainlendar forum, some people are having the same issues I'm having, but not everyone (a really bizarre problem that only affects some users???). So for now, my issue is solved, but not the install problem with rainlendar 2.14. Thanks again.

  • @N0rbert: That’s a different question and OP already did what the accepted answer to the linked question recommends. – David Foerster Oct 13 '18 at 0:37
  • @DavidFoerster N0rbert is right. It is actually the same question here. However, for that user, using Mate, the approach I give here did not work. Two upvotes on the other hand suggest my answer is not bad. You forced me to try it myself, and it works indeed on (standard) Ubuntu 18.04. – vanadium Oct 13 '18 at 7:00
  • @N0rbert Installation using my answer works on Ubuntu 18.04 works (tested it now), so the interesting thing is tht in the other question, it apparently did not work for that user using Ubuntu 18.04 Mate (more safety policies in the Mate edition?) – vanadium Oct 13 '18 at 7:02
  • @vanadium our methods are equal - you install with dpkg -i followed by apt-get install -f to satisfy dependencies; I install with apt-get install ./file.deb to satisfy dependencies with only one command. The problem described in OP question is just a warning. It is known bug 1522675 about _apt user. But I did not see such message on my 18.04 LTS systems. – N0rbert Oct 13 '18 at 7:19
1

The installation succeeded. The message prefixed with N: is a notice about a potential issue that didn’t prevent the installation (or whatever task you gave Apt).

The message is actually caused by the known bug #1522675.

2

APT, the package manager, expects certain working routines and handles certain security policies. You get a warning about the file you want to install. However, the install itself went fine.

Another way to proceed installing downloaded .deb files is with the dpkg command..

sudo dpkg -i rainlendar2-lite_2.14.2.b157-1_amd64.deb

If certain dependencies are not met, the install will not succeed. Then, you can rely on the package manager to download and install all dependencies automatically, and finish the installation with the command

sudo apt-get install -f

This will complete the installation, provided all dependencies required by the deb indeed are available in the software repositories. The installation will not proceed if error messages are issued related to dependencies that cannot be satisfied because they are not available.

Not the answer you're looking for?Browse other questions tagged or ask your own question.