1

I need help to restore my Wi-Fi and DNS settings to previous state like was before installation of KDE connect. Now I have unstable Wi-Fi (every few minutes disconnect), I can ping, mtr from terminal BUT no browse. I have read every tutorial I found but no success. When I click on network manager icon on panel the connection information shows apparently correct. I'm connected to AP through an Wi-Fi repeater (TP-Link wr802n). Is this issue maybe related to Bluetooth ? Appreciate some help, Vladi PS: KDE connect can ping the phone and vice-versa, but nothing else, i don't know how to browse files and so on. I'm using Xubuntu 16.04. thanks

  • I have the same issue!!! I wiresharked a bit and it seems TCP is unhappy with retransmissions. I think the TCP handsake is failing due to receiving things twice but I was not able to research any further yet... (I dont think the bluetooth has anything to do with it, I think is the repeater playing over the same channel) – urban Oct 10 '18 at 16:03
  • Quick update: I did a firmware upgrade on my TL-WA850RE and the problem seems to have gone away! I am not sure if the firmware or the device restart fixed the issue. I still see some TCP dups an retransmissions but things work now. Let us know how it goes and if restarting the repeater solves the issue – urban Oct 10 '18 at 16:54
  • @urban I will restart the repeater and see what happen. Later I'll post the results. thanks – vladimir pavloski Oct 10 '18 at 18:49
  • @urban I restart repeater and so far wifi connection is stable. BUT I removed completely KDE connect ! Very bad experience. Thanks. I'm afraid to reinstall again and get all sorts of WiFi problems. – vladimir pavloski Oct 10 '18 at 20:33
  • @urban Unfortunately I was wrong, the connection is still unstable, what to do? I can ping, mtr, sometimes telnet to port 80 but when I can't browse telnet doesn't work !! I did firmware upgrade to tplink wr802n but no success!! ALL these problems began after installation of KDE connect!! How can I reset every thing and setup again from scratch?? thanks – vladimir pavloski Oct 11 '18 at 18:30
0

I have not gotten to the bottom of this yet so this is not a complete answer. However, I will use it to keep track of what worked for me in various cases and update it.

Symptoms

I see the following symptoms:

  • Ping works most of the time, however, some times it returns (DUP!)
  • Some websites are accessible and some are not. When they are not they timeout
  • Wireshark on the wlan0 interface show lots of TCP errors:
    • TCP Spurious Retransmission
    • TCP Dup ACK
  • Various other devices in the house do not automagically switch to the repeater (I see this from the received signal strength). Bouncing the wifi fixes the issue on Android
  • Various concerning errors in my syslog (can you post yours?)

    $ sudo tail -f /var/log/syslog -n1000 | grep wl_
    Oct 13 11:21:02 urban-asus kernel: [29439.451313] CPU: 2 PID: 493 Comm: wl_event_handle Tainted: P        W  OE   4.4.0-137-generic #163-Ubuntu
    Oct 13 11:21:02 urban-asus kernel: [29439.451464]  [<ffffffffc05cd085>] wl_notify_roaming_status+0xc5/0x140 [wl]
    Oct 13 11:21:02 urban-asus kernel: [29439.451527]  [<ffffffffc05cc6e3>] wl_event_handler+0x63/0x1d0 [wl]
    Oct 13 11:21:02 urban-asus kernel: [29439.451585]  [<ffffffffc05cc680>] ? wl_notify_scan_status+0x320/0x320 [wl]
    Oct 13 11:21:03 urban-asus kernel: [29440.554124] ERROR @wl_cfg80211_get_station : Wrong Mac address, mac = c0:3e:0f:80:db:31   profile =ac:84:c6:c2:7c:73
    Oct 13 11:21:03 urban-asus kernel: [29440.554537] ERROR @wl_cfg80211_get_station : Wrong Mac address, mac = c0:3e:0f:80:db:31   profile =ac:84:c6:c2:7c:73
    Oct 13 11:21:04 urban-asus kernel: [29441.057439] ERROR @wl_cfg80211_get_station : Wrong Mac address, mac = c0:3e:0f:80:db:31   profile =ac:84:c6:c2:7c:73
    Oct 13 11:21:04 urban-asus kernel: [29441.057529] ERROR @wl_cfg80211_get_station : Wrong Mac address, mac = c0:3e:0f:80:db:31   profile =ac:84:c6:c2:7c:73
    Oct 13 11:21:05 urban-asus kernel: [29442.568268] ERROR @wl_cfg80211_get_station : Wrong Mac address, mac = c0:3e:0f:80:db:31   profile =ac:84:c6:c2:7c:73
    Oct 13 11:21:07 urban-asus kernel: [29444.559172] ERROR @wl_cfg80211_get_station : Wrong Mac address, mac = c0:3e:0f:80:db:31   profile =ac:84:c6:c2:7c:73
    Oct 13 12:39:58 urban-asus kernel: [34174.929046] ERROR @wl_dev_intvar_get : error (-1)
    Oct 13 12:39:58 urban-asus kernel: [34174.929051] ERROR @wl_cfg80211_get_tx_power : error (-1)
    

Solutions that worked in the past

Firmware upgrade and repeater reset

I have upgraded the repeater firmware which caused it to reset and that solved the issue the first time. I am not sure if the firmware or the reset did the job...

Locking the BSSID

On infrastructure mode with multiple APs on the same SSID (network name) you can configure your adapter to prefer a particular AP. This morning I experienced the same issues as above and thus I created one network connection that forces the BSSID (mac address) of the repeater.

On KDE from the connection editor (right click on the tray-> Configure Network connections) I created a new connection:

locked BSSID

I still have the original connection to my network that seems to be working as expected when I am closer to the router. When moving rooms this stops working... switching to the above connection did the job today (I will experiment more and see if switching back shows the same symptoms)

You can verify to which AP you are connected with:

$ iwconfig wlan0
wlan0     IEEE 802.11abg  ESSID:"Urban - Sky"  
          Mode:Managed  Frequency:2.472 GHz  Access Point: AC:84:C6:C2:7C:73   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

Try another wifi card

I have seen incompatibility issues with various routers where my card stops working and the connection needs to be reset. In this case it doesn't seem to be the case since I can still ping the router fine. However, I do have a USB wifi interface and I will experiment and see if it shows the same symptoms. If not, then it might be a card or driver issue (will update this section when I find some time to do the tests)

Let me know if any of the above solves the problem

  • I did some research and found some thing interesting : This router/repeater TL WR802n is a junk cheap router and a cause of all issues can be that on TP LINK configuration page should be set DNS servers like 8.8.8.8,8.8.4.4 or a OPENDNS and should be done release or flush DNS on the router and on the computer. I hope these suggestions can help. thanks. – vladimir pavloski Oct 13 '18 at 18:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.