1

Install in the terminal it puts out this:

alexeya@RC530:~$ sudo dpkg -i gitkraken-amd64.deb
Selecting previously unselected package gitkraken.
(Reading database ... 239444 files and directories currently installed.)
Preparing to unpack gitkraken-amd64.deb ...
Unpacking gitkraken (4.0.5) ...
dpkg: dependency problems prevent configuration of gitkraken:
gitkraken depends on gconf2; however:
Package gconf2 is not installed.

dpkg: error processing package gitkraken (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
gitkraken

I can not run app Gitkraken

There are questions like this one but mine is not the same and has a different error message. I have tried the proposed fixes for the other ones.

  • What did you try and what was the outcome? Did you already try installing gconf2? Please edit to add details. – wjandrea Oct 9 '18 at 19:11
  • "Package gconf2 is not installed.". 1st step: sudo apt install gconf2. Then retry. – waltinator Oct 9 '18 at 19:26
0

You should not install individual package with dpkg -i. If you are doing so you must to run sudo apt-get install -f afterwards.

The better way is to use apt-get install for deb-package as follows:

cd ~/Downloads
wget https://release.gitkraken.com/linux/gitkraken-amd64.deb
sudo apt-get install ./gitkraken-amd64.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.