I set up my printer successfully on 10.04, 12.04, 14.04 and 16.04, there were various troubles, but I still could manage to resolve it in the end.

It's 18.04 (64 bit, after upgrading from 16.04 64 bit) where I don't seem to be able to figure it out. Admittedly, the scanner part works for me, but not printer.

The printer is present and recognized. When it is off, the system correctly marks jobs as "waiting for printer to be available". However, if printer is on and connected, it accepts jobs to only dismiss them as "completed" jobs from the user "Withheld" (I googled it, it's CUPS thing and it is fine) the very next moment. No actual printing happens, test page or not.

The printer actually worked for me on 16.04 before upgrading to 18.04, so I don't believe the device is to blame.

So. What I've tried so far (besides re-installing CUPS, rebooting and reconnecting the USB cable).

  1. The official Brother way. Went to MFC-7420 Downloads, got the installer script which installed the LPR and CUPS Wrapper drivers for MFC-7420 (both of i386 architecture) and scanner drivers (as I said above, the scanner part works with some hints from Internet).

  2. The less official way. There are amd64 packages that exactly suit (well, in theory) my MFC-7420:

    $ dpkg -l | grep brother
    ii  brother-cups-wrapper-common  1.0.0-10-0ubuntu7 amd64  Common files for Brother cups wrapper packages
    ii  brother-cups-wrapper-laser   2.0.1-2-0ubuntu7  amd64  Cups Wrapper drivers for laser brother printers
    ii  brother-lpr-drivers-common   1.0.0-4-0ubuntu3  amd64  Common files for brother-lpr-drivers packages
    ii  brother-lpr-drivers-laser    2.0.1-3-0ubuntu5  amd64  LPR drivers for laser brother printers
  3. Switched between (recommended) "MFC-7450 BR-Script3" and (apparently installed with packages above) "MFC-7420 for CUPS" drivers.

  4. Completely removed any MFC-7420-related package or driver to start over from the blank.

  5. Googled a lot, but then mostly it all points back to the Brother site which is p.1.

So, the problem is still on. I want to print, but the printer just doesn't. Any insights?

3 Answers 3


I had a similar issue with my DCP-7055 after upgrading from 16.04 to 18.04. Installed / reinstalled CUPS and used the Brother installation script. Even the scanner worked! Through the looking glass.

My issue was fixed by following the answer here, "18.4 - Printer 'Filter failed'.

  • That answer indeed fixes the problem. After doing the thing I switched to MFC-7420 for CUPS model in the printer settings with the amd64 drivers installed (those from universe/multiverse repositories) and that was it. Thanks for finding that one out for me.
    – Organis
    Oct 15, 2018 at 20:04

I successfully installed my brother mfcj480dw by first downloading the driver from brother (I did the full install package) then first

sudo chmod +x linux-brprinter-installer*


sudo ./linux-brprinter-installer*

Then I followed the prompts as they appeared in the terminal window (y/n), etc.

I also went for the USB install to avoid having to deal with network stuff.

  • Lucky you, then. The problem was not within Brother software (which, I pointed that out, I had good experiences with since quite a long ago), but probably within the fact I dist-upgraded from 16.04 to 18.04 (at least, maybe because I did it since 12.04) rather then installing a clean 18.04 and some things (along with the missing ICC profile files) went missing.
    – Organis
    Nov 2, 2018 at 9:11

Possibilities are, the driver you installed may be generic one or default one. In that case if u try to send a file with some extentions will not work. Things to do.

  1. Try to print a basic txt file with a few lines you typed.

  2. Check the right driver has been installed.

* Some file extensions or long filenames with special characters can too cause this sort of issue.

  • Thanks for your reply, but... 1) Tried to print from stdin per suggestion here askubuntu.com/a/574540/880132 - the result is still same: the job is accepted then marked as completed while no actual printing occurs. 2) As I pointed above, this is not the first time I'm doing this thing (albeit I succeeded on previous releases), I tried the printer-specific drivers that official installer pulled, I tried the generic drivers (I specifically checked that MFC-7420 is listed in these packages, like packages.ubuntu.com/bionic/amd64/brother-lpr-drivers-laser/…).
    – Organis
    Oct 9, 2018 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.