1

At first glance this sounds like a duplicate of Can't change text size in gedit, but it isn't: in that question they're actually talking about print size, I'm not.

I'm using Ubuntu 14.04 and Gedit 3.10.4.

Anyway - last week, to let one of my kids play with the text editor, I changed the default text size to be large, on the Edit/Preferences/"Font and Colour" tab. Now, I can't change it back - I tick on the box to use the default "Ubuntu Monospace 13" font, and the box is ticked and then unticks itself straight away. I can change the font size instead, and the change just reverts as soon as it's saved.

I think it might be due to some config file which has the wrong permissions: if I open Gedit in sudo mode, I can change the font size. But the change made here doesn't cross over back into "non-sudo" gedit.

The only config file I can find in home is ~/.config/gedit/accels and the permissions are normal on that. I think that's just a list of keyboard shortcuts anyway. There's lots of other config files in /usr/share/gedit/ but none of them show as being modified recently.

I've tried uninstalling and reinstalling gedit but it didn't make any difference.

Any ideas anyone?

  • When you uninstall gedit it keeps the configuration unless you use the --purge flag. – WinEunuuchs2Unix Oct 9 '18 at 10:40
  • ah, i'll try again....nope, didn't help. I just noticed that it's all of the options that are locked, not just the font size. – Max Williams Oct 9 '18 at 13:55
1

It sounds similar to this problem: gedit "Manage External Tools" menu option doesn't appear

Use namei to find if sudo owns some of your configuration files:

$ namei -l ~/.config/gedit/tools
f: /home/rick/.config/gedit/tools
drwxr-xr-x root root /
drwxr-xr-x root root home
drwxr-xr-x rick rick rick
drwx------ rick rick .config
drwxr-xr-x root root gedit
drwxrwxr-x rick rick tools

If you see root appear as owner or group (after the first two directories, / and home) then use this command:

sudo chown -cR user:user /home/user

Where user is your user ID. ie Max:Max /home/Max

  • Thanks. I don't have ~/.config/gedit/tools - the only thing I have is ~/.config/gedit/accels and the path down to that is all owned by max:max (my user/group). – Max Williams Oct 9 '18 at 13:38
  • chowning my whole home dir (as in that question) didn't help either, unfortunately. – Max Williams Oct 9 '18 at 14:00
  • I've uninstalled gedit and deleted everything I can find on my whole drive, that mentions gedit. Then after installing it again I have the same problem... – Max Williams Dec 3 '18 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.