1

I've tried a few ways online (though they seem to be different ways of doing the same thing). And I always get this message: An upgrade from 'zesty' to 'bionic' is not supported with this tool. I saw in another post on this forum, that you have to upgrade in order? Meaning, I apparently need to upgrade my 17.04 installation to 17.10, and then I can upgrade to 18.04. Which is fine, I have enough free time to do that, however... how? How do I upgrade from 17.04 to 17.10 now that 18.04 is out?

And I would highly appreciate a solution that doesn't just involve reinstalling the OS. Because while I do already have a flash drive with 18.04 on it via Rufus, I do not have the knowledge of Linux required to get all my save data for my applications (namely games), and back it up, because I don't understand where Linux and it's applications store their data.

Finally, I don't know if this matters at all, but just so it's on the record: this is a dual boot setup. PC had Windows, before I slipped Ubuntu in the side :p .

-- I would like to reiderate, that I want to upgrade from 17.04 to 17.10, and then from 17.10 to 18.04. I would also like to point out that the official upgrade tutorial does not seem to bother mentioning that 17.04 users will have a hard time (or possibly even can't!) upgrade, which is odd to me only because it does mention that for users on 15.10, to read an upgrade notes page on the Ubuntu site. So they are aware of people trying to do large leaps in versions.

EDIT:

For this: How to install software or upgrade from an old unsupported release?

I get an error when executing the second command in the answer:

E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi'
E: Sub-process returned an error code

Another Question:

If I put a 17.10 iso on a flash drive, and booted from that, would I be given the option to upgrade to that version? The reason I ask, instead of just trying it myself, is because I'd rather not waste the time downloading such a large file, for it not to work.

marked as duplicate by muru, mook765, karel, user535733, Thomas Oct 9 '18 at 6:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @M.A.K.Ripon Not upgrading from 17.10, I'm trying to upgrade from 17.04. – Magicrafter13 Gaming Oct 9 '18 at 4:00
  • @muru you may be correct with the duplicate, though my intention is not to skip over a release, I actually wanted to figure out how to go from 17.04 to 17.10 – Magicrafter13 Gaming Oct 9 '18 at 4:24
  • @Magicrafter13Gaming that's covered by tudor's dupe. – muru Oct 9 '18 at 4:29
  • @muru I tried that one already - gives me an error. – Magicrafter13 Gaming Oct 9 '18 at 4:53
  • See askubuntu.com/questions/943463/… – muru Oct 9 '18 at 5:07
1

Follow the steps below to upgrade to a new release:

sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak #to be safe
sudo sed -i -re 's/old-releases.ubuntu.com/archive.ubuntu.com/g' /etc/apt/sources.list
sudo sed -i -re 's/zesty/artful/g' /etc/apt/sources.list
sudo apt-get update
sudo apt-get dist-upgrade

Replace everything in /etc/apt/sources.list with this:

## EOL upgrade sources.list
# Required
deb http://old-releases.ubuntu.com/ubuntu/ artful main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ artful-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ artful-security main restricted universe multiverse

# Optional
#deb http://old-releases.ubuntu.com/ubuntu/ artful-backports main restricted universe multiverse

Try the steps below if you still failed to upgrade.

sudo apt-get install update-manager-core
sudo do-release-upgrade

It is also possible to use do-release-upgrade to upgrade to a development version of Ubuntu. To accomplish this use the -d switch:

sudo do-release-upgrade -d
  • 4
    That won't work with EOL releases. – tudor Oct 9 '18 at 4:05
  • Just tried it twice, didn't work. – Magicrafter13 Gaming Oct 9 '18 at 4:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.