0

I had just finished upgrading, and now, when I restarted the system to complete the installation process, Ubuntu does not start.

The boot menu and GRUB work fine, leading me to the boot menu when I request it. But instead of booting, the system is stuck at a frozen light grey screen bound by a darker grey border. I tried entering recovery mode, but it doesn't work. What am I supposed to do now?

The upgrade process ended, but I remember reading a line which said that there were errors. How should I solve this problem?

By the way, I have NVIDIA drivers installed, and recently I had been experimenting with KVM virtual machines.

EDIT: I tried to follow this tutorial, which was a failed attempt at trying to transfer the GPU to a virtual machine instance that ran on KVM. Do you think I could have messed up something there?

0

I was finally able to solve the problem. It was the NVIDIA drivers after all. I couldn't access the terminal in any way. So, I had use the liveCdRecovery method to gain access to the system (https://help.ubuntu.com/community/LiveCdRecovery#Update_Failure):

#Boot the Ubuntu Live CD.

#Press Ctrl-Alt-F1

sudo mount /dev/sda1 /mnt

sudo mount --bind /dev /mnt/dev

sudo mount --bind /proc /mnt/proc

sudo mount --bind /sys /mnt/sys

sudo chroot /mnt

This basically gives access to the 'terminal', from the context of the system that has to be repaired. And that's it! I used purge on the NVIDIA drivers, and the system finally booted.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.