1

TLDR version:

Once you have a fresh install of Ubuntu 18.04 (and has updated all the existing software on the system immediately after install) and your laptop run llvmpipe for grahics, what is the best practice/proper way to configure the system to instead use either the Intel GPU (preferred) or the Nvidia GPU (if necessary) for graphics?

Only "special" setting upon install was to select "nomodeset" before starting the install (as I only got a blank screen instead of an Ubuntu installation otherwise)

(I've tried googling and following what seems to be obvious best practice but the system still insists to run... llvmpipe)

Worth noting, on Ubuntu 16.04 on the same laptop, the Intel GPU worked as a charm for accelerating the graphics.

Any assistance would be greatly appreciated!

FULL version:

I installed Ubuntu 18.04 on my 6 year old Sony Vaio S15 on a new SSD (fresh install from scratch) and noticed upon boot that the machine did not use any of the GPUs (neither Intel integrated nor Nvidia). Settings -> Details listed "Graphics: llvmpipe (LLVM 6.0, 256bits)".

After a couple of hours of googling and testing various apparent best practices as well as obvious work-arounds (ok, hacks admittably) I still had not managed to get the machine to not use llvmpipe.

(Worth noting, I strongly prefer the intel GPU over the Nvidia for various reasons: the Intel GPU is by far good enough for my needs and not so hard on power consumption and heat generation.)

So, instead of spending 2 full weeks (that I honestly cannot afford, my sincere apologies) going full brute force, use my 30-year X-windows experience, troubleshoot and disassemble the entire Xorg setup on the poor machine (and reinventing some other peoples wheels in the process), I decided to do things a more mature and time efficient way:

Reinstall one more time and then post a question here, asking how to best (as in "best practice") proceed from here. Hopefully to get a GPU activated of course (esp the Intel one), but if that proves impossible with a reasonable effort, at least done "everything right" to file a bug report of an acceptable quality.

The gory details:

lspci -k | grep -A 2 VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
    Subsystem: Sony Corporation 3rd Gen Core processor Graphics Controller
    Kernel modules: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M LE] (rev a1)
    Subsystem: Sony Corporation GK107M [GeForce GT 640M LE]
    Kernel modules: nvidiafb, nouveau

strong text Errors and warnings in /var/log/Xorg.0.log

grep -P 'EE|WW' /var/log/Xorg.0.log
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     5.362] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[     5.362] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[     5.362] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[     5.362] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[     5.363] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[     5.370] (EE) open /dev/dri/card0: No such file or directory
[     5.370] (WW) Falling back to old probe method for modesetting
[     5.370] (EE) open /dev/dri/card0: No such file or directory
[     5.370] (WW) Falling back to old probe method for vesa
[     5.370] (EE) Screen 0 deleted because of no matching config section.
[     5.377] (EE) AIGLX: reverting to software rendering

The kernel boot command line:

cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-4.15.0-36-generic root=UUID=5d0e9eea-214e-45ab-b7c5-47f6158ae330 ro nomodeset quiet splash vt.handoff=1
  • Try selecting "Wayland" under the login gear choices. That should force the intel graphics. Should work fine, I've seen no problems since this choice recently became available with Nvidia present. – ubfan1 Oct 8 '18 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.