6

I found some related questions, e.g. Ubuntu 18.04 lts freezes while in boot, in wndows Virtual box. Solution?, but my case a is a big different:

I am running VMware Workstation 14.1.3 on a server with Intel(R) Xeon(R) CPUs E5-1650.

I had a VM with Ubuntu 14.04 with four cores, which I upgraded to Ubuntu 18.04. The kernel is 4.15.0-36-generic.

Since the upgrade, the VM won't boot anymore, it gets stuck at "Booting SMP configuration".

If I change the VM to have one core only, it boots successfully.

Also, I can boot by choosing a 4.4.0 kernel during the boot process.

I cannot apply any of the Virtualbox-specific options, has anybody else experienced this with VMware and knows how to fix it?

Update:

I had a look at the vmware.log for the VM, and the last entries are these:

2018-10-09T13:43:12.054+02:00| vcpu-0| W115: CPU microcode update available.
2018-10-09T13:43:12.054+02:00| vcpu-0| W115+ The guest OS tried to update the microcode from patch level 60 (3Ch) to patch level 61 (3Dh), but VMware Workstation does not allow microcode patches to be applied from within a virtual machine.
2018-10-09T13:43:12.054+02:00| vcpu-0| W115+ Microcode patches are used to correct CPU errata. You may be able to obtain a BIOS/firmware update which includes this microcode patch from your system vendor, or your host OS may provide a facility for loading microcode patches.CPU reset: soft (mode 0

However, these are only warnings, so I suppose it does not play a role.

0
10

I bumped against this as well for several days. Had an idea based off of reading the esxi logs about failing to apply an intel mcirocode update and decided to see if it was possible to remove it and sure enough that fixed it.

Post I got the idea from: https://ubuntuforums.org/showthread.php?t=2273643

Had to boot into reovery mode to execute the following commands: https://wiki.ubuntu.com/RecoveryMode

Commands I ran to get it working.

sudo dpkg -l|grep intel
sudo apt-get purge intel-microcode
sudo update-grub
sudo reboot
1
  • 1
    Also fixed my situation. Thanks!!! Nov 26 '19 at 1:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.