13

After upgrading to 18.04, I find that the File Manager will not allow sorting (date, type, name etc) after a search. It does allow sorts prior to a search.

This change is not an improvement.

  • 1
    If you're missing features in Nautilus I recommend using Nemo. Nemo was forked from Nautilus some time ago. It still feels very similar but was not reduced in features like Nautilus was. – pLumo Oct 8 '18 at 14:26
  • I added an new issue on github gitlab.gnome.org/GNOME/nautilus/issues/888 but it seems that there is no intenstion so solve that behaivier. Upvote the issue anyway! – wittich Feb 8 '19 at 21:39
4

1. Krusader

While Nautilus is the default file manager, there exist other like Krusader file manager.

  • It can be installed with

    sudo apt-get install krusader
    
  • Open with Super+A, and enter krusader and than Enter. It provides a powerful search gui, eg sorting the search-results.

  • If you want to set Krusader as the default file manager, run this command in Terminal:

    xdg-mime default krusader.desktop inode/directory application/x-gnome-saved-search
    gsettings set org.gnome.desktop.background show-desktop-icons false
    

    To test that change type

    xdg-open $HOME
    
  • To revert this enter

    xdg-mime default nautilus.desktop inode/directory application/x-gnome-saved-search
    gsettings set org.gnome.desktop.background show-desktop-icons true
    

enter image description here


2. Nemo

  • It can be installed with

    sudo apt-get install nemo
    
  • Open with Super+A, and enter nemo and than Enter. It provides a powerful search gui, eg sorting the search-results.

  • If you want to set Nemo as the default file manager, run this command in Terminal:

    xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search
    gsettings set org.gnome.desktop.background show-desktop-icons false
    

    To test that change type

    xdg-open $HOME
    
  • To revert this enter

    xdg-mime default nautilus.desktop inode/directory application/x-gnome-saved-search
    gsettings set org.gnome.desktop.background show-desktop-icons true
    

enter image description here

  • Why gsettings set org.gnome.desktop.background show-desktop-icons false? The desktop shell seems to interop fine – cat Oct 22 '18 at 0:55
4

You need to click on the drop down icon on the right of the text searched.

screenshot

For sorting from the columns that appears not to be the default settings anymore. As of now the bug is reported here.

You can try other file managers like Thunar or PCMan File Manager which may offer same functionality.

  • 2
    As far as I can tell, this still doesn't let you sort the results. It just gives you options like searching for certain dates or file types. – Paul Jones Feb 17 '19 at 18:15
1

Allowing sorting was removed from Nautilus, and instead replace by sorting for "relevance" without a clear idea of what that means. See: https://gitlab.gnome.org/GNOME/nautilus/issues/209 and https://gitlab.gnome.org/GNOME/nautilus/issues/374 and https://bugzilla.gnome.org/show_bug.cgi?id=778484

As with other suggestions, the only way to have this functionality is to replace nautilus with another file manager. Caja is a good option (default in Mate desktop, fork of Nautilus from Gnome 2), and also has caja extensions (apt-cache search caja-).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.