0

Few days ago after restart ubuntu (16) won't boot again.

System asks for disk encryption password, after this step screen goes black and switches between black and dark grey, with white dash appearing sometime on top left, sometimes not.

It looks like it is trying to start but it won't go through.

I decided so to reinstall everything, but I would like to backup my home before doing so.

But the problem is: when I start in recovery mode and I drop to root shell prompt, this only lasts for a few minutes - after that it opens the recovery menu again and does not accept input from keyboard again.

This way it is not possible for me to make a proper backup before reinstalling the system (I can remount in write mode, login as user, mount the disk, start the syncing... but after few minutes it kicks me out!!!).

Any clue on how to enter a "stable and long lasting" recovery prompt?

Or what am I doing wrong?

Any help very much appreciated, thank you!

  • Try booting off of the OS media. The try Ubuntu option should give you interactive capabilities. You can then access the disk and back up any data on it before doing anything else. – Lewis M Oct 8 '18 at 12:22
  • @LewisM, thanks!I have tried tryUbuntu from live drive, but home encrypted won't let me backup it. I have then followed instructions for using encryptfs tools, but it only goes for a no-ending search, so I gave up this option as well. – raffaele Oct 8 '18 at 12:27
  • I have also tried to reboot with no quite splash option and nomodeset options. Having a ASUS N76 with nvidia card, I have also tried to reboot deactivating the card. Anything so far did not work. – raffaele Oct 8 '18 at 12:30
  • Have you tried booting into single user mode? – Lewis M Oct 8 '18 at 12:32
  • Thank you! No, I have no tried and I am trying now after your suggestion. Before "Please unlock disk" I get error messages: uncleared pch fifo underrun... PCH transcoder A FIFO underrun lvmetad is not active yet, using direct activation during sysinit Volume group ubuntu-vg not found Cannot process volume group ubuntu-vg I then insert password for encryption, which takes me to the terminal mode. But error lvmetad.socket connect failed persists. After remounting in write/read mode, I try to login as user1 to be able to access the home, but message "System is booting up. See pam_login" – raffaele Oct 8 '18 at 13:00
0

I have found a work around my problem (took days, I hope this can be useful for someone in the future not to waste as much time as I did).

This applies when you (userX) won't be able to:

0) boot your Ubuntu (16 in my case) in normal mode

1) open your encrypted home (/home/userX) with a live distro (you may have forgotten your passphrase...)

2) when your recovery mode does not last long enough to permit you to backup your data (I still have no clue why this happens!, the first time I get this behavior)

My work around was (and thanks a million to Lewis M for the suggestions and help, really!):

  • boot in single user mode (so you are root)

  • delete (or move somewhere else) the file /run/nologin

  • login as userX (you cannot if the file /run/nologin exists [at least in my case])

  • you should now be able to access /home/userX and backup your data (at least the session does not collapse anymore after a few minutes)

Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.