1

This question already has an answer here:

After an upgrade from 16.04 to 18.04 my printer stopped working. The printer is an Epson E360-dn. After printing a test page the I get the message Printing followed by Printing Stopped with the Printer's state message saying "Filter Failed". The printer is network attached. After reading about similar problems and trying different things (reinstalled cups; sudo aa-complain cupsd then systemctl restart cups.service; deleted printer and reattached as a usb device; dug through the error logs) I am at a loss as to where to go next.

The only error message I can find in /var/log/cups/error_log is an error 32 (Broken pipe)

 cindy@Calanthe3:/var/log/cups$ tail error_log
    I [08/Oct/2018:17:10:45 +1000] Expiring subscriptions...
    D [08/Oct/2018:17:10:45 +1000] [Client 126] con->http=0x5573beab3140
    D [08/Oct/2018:17:10:45 +1000] [Client 126] cupsdWriteClient error=0, used=0, state=HTTP_STATE_POST_SEND, data_encoding=HTTP_ENCODING_LENGTH, data_remaining=106, response=0x5573bea747d0(IPP_STATE_DATA), pipe_pid=0, file=-1
    D [08/Oct/2018:17:10:45 +1000] [Client 126] Writing IPP response, ipp_state=IPP_STATE_DATA, old wused=0, new wused=0
    D [08/Oct/2018:17:10:45 +1000] [Client 126] bytes=0, http_state=0, data_remaining=106
    D [08/Oct/2018:17:10:45 +1000] [Client 126] Flushing write buffer.
    D [08/Oct/2018:17:10:45 +1000] [Client 126] New state is HTTP_STATE_WAITING
    D [08/Oct/2018:17:10:45 +1000] [Client 126] Waiting for request.
    D [08/Oct/2018:17:10:45 +1000] cupsdSetBusyState: newbusy="Dirty files", busy="Active clients and dirty files"
    I [08/Oct/2018:17:10:46 +1000] Expiring subscriptions...
    cindy@Calanthe3:/var/log/cups$ tail error_log
    D [08/Oct/2018:17:11:01 +1000] [Client 126] HTTP_STATE_WAITING Closing for error 32 (Broken pipe)
    D [08/Oct/2018:17:11:01 +1000] [Client 126] Closing connection.

I tried re-booting from a 18.04 live usb. I installed the printer with just the default drivers and printing worked out of the box. Clearly this is related to the upgrade process. Any ideas of what needs to be reset to defaults or reinstalled for this printer to work?

marked as duplicate by pomsky, Kulfy, Zanna, Thomas, Charles Green Jan 1 at 16:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4

I had a similar problem after upgrading to 18.04. The steps in this answer fixed it:

sudo rmdir /usr/share/ghostscript/9.25/iccprofiles
sudo apt-get install --reinstall libgs9-common
  • Brilliant! That fixed it. Only difference was I had to use 'sudo rm /usr/share/ghostscript/9.25/iccprofiles' since it told me it wasn't a directory. Thank you – Cindy P Oct 22 '18 at 7:14
0

I had a similar problem with a previously working Canon printer on 16.04, connected via USB. Having done a distro upgrade to 18.04, the same 'Filter failed' message appeared when attempting to print. error_log contained a few spurious splutters before giving up with 'Unrecoverable error: rangecheck in .putdeviceprops', not useful in itself but symptomatic of an ill printer system.

I tried 'apt purge' on both cups and ghostscript packages; purging cups alone or just removing and reinstalling these packages were insufficient, they both needed purging. Reinstalling ghostscript then cups cured the problem for me - the upgrade process must be faulty.

  • Thanks MC3141 but that didn't work for me. I tried apt purge ghostscript and cups then apt autoremove followed by reboot. apt-get install ghost script then cups followed by adding printer (let the system choose the drivers). Still same printer stopped with 'filter failed'. The logs look similar as well. I am not sure what else is hanging around nor how to find it. – Cindy P Oct 12 '18 at 5:07
0

I also had problems on two different computers with two previously working Canon printers on 16.04, also connected via USB. After a distro upgrade to 18.04 neither worked. This was two different computers, and two different cannon model printers (one MX and one IP).

On both systems had CUPS service crashing showing error:

"error: Failed to create /var/spool/cups/tmp/.hplip"

Sure enough permission issues were present.

Used fix:

sudo apt remove hplip
sudo apt install hplip

CUPS was then running but issue persisted. Found errors using "cat /var/log/cups/error_log | tail" Each system had different errors. One "filter failure", the other "Dirty files". but both were fixed after fix mentioned by musashiXXX

sudo rmdir /usr/share/ghostscript/9.25/iccprofiles
sudo apt-get install --reinstall libgs9-common

Worked like a charm. Not sure if the purge/reinstall would have worked to start with.

Not the answer you're looking for? Browse other questions tagged or ask your own question.