1

After upgrading to Ubuntu 18.04, I can't find xkill on pressing Alt+F2. Instead it shows a message box with a text-field titled as Enter a Command.

How can I find xkill on Ubuntu 18.04 and what is the purpose of this new window?

6

One Linux keyboard shortcut gives you quick access to all of your software and some useful commands. It’s like a portable command line, and it’s probably already built into your Linux distro of choice. Just hit “Alt” and “F2” at the same time to get started. Whether you want to force-quit a hanging application or quickly launch your favorite text editor, this shortcut is indispensable for Linux users.

Most long-time Linux users are probably already familiar with Linux keyboard shortcuts, but new Linux converts might not have discovered this simple shortcut yet. They should, because once you get used to using it you’ll wonder how you ever lived without it. It’s a great way to quickly launch your favorite applications, and can be used to do much more.

You need to type xkill in Enter a command prompt and hit Enter.

  • Unity used to have this kind of interface when Alt+F2 was used:

    That was basically interface for entering a command with label Run a Command and Not a Dashboard(However it seems to be and that's what you are referring to.). It used to show suggestions as you type.

  • But in GNOME interface is like this:

    And yes this doesn't show any sort of suggestions.

You can either create a Desktop Entry or define a keyboard shortcut in Settings → Devices → Keyboard to use xkill quickly.

  • 1
    why typing instead of just easy on selecting in previous version. – M.A.K. Ripon Oct 6 '18 at 19:32
  • 2
    @M.A.K.Ripon Added in edit – Kulfy Oct 6 '18 at 19:46
  • 3
    @M.A.K.Ripon Because Ubuntu switched from Unity to GNOME. GNOME shell has this <Alt>+<F2> prompt for a long time. – pomsky Oct 6 '18 at 19:51
  • 1
    @pomsky Edited the answer and added more details – Kulfy Oct 6 '18 at 20:11
  • 3
    Tab completion in that dialog will work, however only when there is one single possibility. So in case of xkill, you need to type "xki" before tab will autocomplete. – vanadium Oct 7 '18 at 6:24
3

Make yourself a Keybinding

The package involving xkill is x11-utils. If not already installed:

sudo apt install x11-utils

Now press Super+A and type xkill Enter.

Or set a new keybinding in Settings -> Devices -> Keyboard

enter image description here

Quit - Gnome Extensions

Adds a force quit button which launches xkill. On accidental click, right click to undo or click on the panel. Customize position by tweaking line 27 of extension.js

Extension Homepage: https://github.com/meghprkh/force-quit/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.