20

I upgraded my kernel today with ukuu, and since then I cant boot because i'm getting this errors:

error: /boot/vmlinuz-4.18.12-041812-generic has invalid signature
error: you need to load the kernel first

I have dual boot with windows 10 and ubuntu 18.10 (Upgraded today)

Update: I managed to boot to older kernel that i chose from "Advanced options for Ubuntu" in grub

But I need to upgrade my kernel and if I do that I still get the same problem...

  • I'm experiencing this same problem now after updating the firmware of my Lenovo T480 and I don't understand why the older kernels still work. – user205301 Sep 23 '19 at 9:00
12

https://github.com/jakeday/linux-surface/blob/master/SIGNING.md has more specific instructions on kernel signing (adapted from the same tutorial linked in the accepted answer). The instructions are reproduced in full as follows:

Signing a custom kernel for Secure Boot

Instructions are for ubuntu, but should work similar for other distros, if they are using shim and grub as bootloader. If your distro is not using shim (e.g. Linux Foundation Preloader), there should be similar steps to complete the signing (e.g. HashTool instead of MokUtil for LF Preloader) or you can install shim to use instead. The ubuntu package for shim is called shim-signed, but please inform yourself on how to install it correctly, so you do not mess up your bootloader.

Since the most recent GRUB2 update (2.02+dfsg1-5ubuntu1) in Ubuntu, GRUB2 does not load unsigned kernels anymore, as long as Secure Boot is enabled. Users of Ubuntu 18.04 will be notified during upgrade of the grub-efi package, that this kernel is not signed and the upgrade will abort.

Thus you have three options to solve this problem:

  1. You sign the kernel yourself.
  2. You use a signed, generic kernel of your distro.
  3. You disable Secure Boot.

Since option two and three are not really viable, these are the steps to sign the kernel yourself.

Instructions adapted from the Ubuntu Blog. Before following, please backup your /boot/EFI directory, so you can restore everything. Follow these steps on your own risk.

  1. Create the config to create the signing key, save as mokconfig.cnf:
# This definition stops the following lines failing if HOME isn't
# defined.
HOME                    = .
RANDFILE                = $ENV::HOME/.rnd 
[ req ]
distinguished_name      = req_distinguished_name
x509_extensions         = v3
string_mask             = utf8only
prompt                  = no

[ req_distinguished_name ]
countryName             = <YOURcountrycode>
stateOrProvinceName     = <YOURstate>
localityName            = <YOURcity>
0.organizationName      = <YOURorganization>
commonName              = Secure Boot Signing Key
emailAddress            = <YOURemail>

[ v3 ]
subjectKeyIdentifier    = hash
authorityKeyIdentifier  = keyid:always,issuer
basicConstraints        = critical,CA:FALSE
extendedKeyUsage        = codeSigning,1.3.6.1.4.1.311.10.3.6
nsComment               = "OpenSSL Generated Certificate"

Adjust all parts with to your details.

  1. Create the public and private key for signing the kernel:
openssl req -config ./mokconfig.cnf \
        -new -x509 -newkey rsa:2048 \
        -nodes -days 36500 -outform DER \
        -keyout "MOK.priv" \
        -out "MOK.der"
  1. Convert the key also to PEM format (mokutil needs DER, sbsign needs PEM):
openssl x509 -in MOK.der -inform DER -outform PEM -out MOK.pem
  1. Enroll the key to your shim installation:
sudo mokutil --import MOK.der

You will be asked for a password, you will just use it to confirm your key selection in the next step, so choose any.

  1. Restart your system. You will encounter a blue screen of a tool called MOKManager. Select "Enroll MOK" and then "View key". Make sure it is your key you created in step 2. Afterwards continue the process and you must enter the password which you provided in step 4. Continue with booting your system.

  2. Verify your key is enrolled via:

sudo mokutil --list-enrolled
  1. Sign your installed kernel (it should be at /boot/vmlinuz-[KERNEL-VERSION]-surface-linux-surface):
sudo sbsign --key MOK.priv --cert MOK.pem /boot/vmlinuz-[KERNEL-VERSION]-surface-linux-surface --output /boot/vmlinuz-[KERNEL-VERSION]-surface-linux-surface.signed
  1. Copy the initram of the unsigned kernel, so we also have an initram for the signed one.
sudo cp /boot/initrd.img-[KERNEL-VERSION]-surface-linux-surface{,.signed}
  1. Update your grub-config
sudo update-grub
  1. Reboot your system and select the signed kernel. If booting works, you can remove the unsigned kernel:
sudo mv /boot/vmlinuz-[KERNEL-VERSION]-surface-linux-surface{.signed,}
sudo mv /boot/initrd.img-[KERNEL-VERSION]-surface-linux-surface{.signed,}
sudo update-grub

Now your system should run under a signed kernel and upgrading GRUB2 works again. If you want to upgrade the custom kernel, you can sign the new version easily by following above steps again from step seven on. Thus BACKUP the MOK-keys (MOK.der, MOK.pem, MOK.priv).

| improve this answer | |
  • 1
    Ecxellent response, i couldn't have got there with the ubuntu instructions alone – User632716 Jan 21 at 15:49
  • 1
    Great shortcut to rename and overwrite files with postfixes. – Tom Mar 17 at 6:41
  • 1
    Very detailed answer. It worked great for me with Ubuntu 20.04 and kernel 5.8. – Andyc Sep 6 at 5:48
  • This needs to be the accepted answer. – Genom Sep 10 at 22:05
10

Instead of signing the kernel in question, I just turned off Secure Boot in the BIOS/UEFI menu of my laptop.

You can usually enter the menu by pressing a special key during boot, you can google the specific one for your device or it might even be shown on screen during boot.

| improve this answer | |
  • 1
    Thanks! I've just updated my BIOS and forgot to disable that! – Lucas Bustamante Jun 17 '19 at 19:27
  • This is working for me! – Jonathan Apr 12 at 20:04
  • This worked on Ubuntu 20.04 👍🏻 – Anirudha Mahale Aug 1 at 13:10
  • Fortunately that answer cam first from Google. Also forgot about that secure boot thing, after a BIOS update. Scary problem that has a simple solution. Thanks! – e2-e4 Aug 18 at 16:33
0

I solved my problem following this tutorial to sign /boot/vmlinuz file for secure boot, Just notice the last part of the tutorial

| improve this answer | |
  • 7
    Could you provide please some detailed information about resolving this problem? I have absolutely the same error, but I do not understand what I have to do according to tutorial mentioned. – Slon Feb 17 '19 at 19:35
  • I don't remember right now, I'll try to help you later this day if its still relevant – Nadav Shabtai Mar 12 '19 at 9:58
  • It is relevant for me too. I have the same issue – Vitalii Diravka Mar 25 '19 at 21:41
  • Just found this, I need it too – Mitch Talmadge Mar 26 '19 at 20:25
  • 3
    This appears to be a "link-only answer". Please edit the question and provide a few details to help out other users who have the same problem. Thanks! – mchid Jul 30 '19 at 1:02
0

I had this issue after updating today. Changing the bootloader to shimx64.efi seems to have fixed it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.