1

Don't mark this question as "already answered", because I searched and there's no post that could help me.

Like the title said, I wanna install Celestia. I already downloaded the packages from the official page (https://celestia.space/download.html) and then, I tried all the things that I found on some posts (also, they're outdate, cause the last one is for Ubuntu 16.04) but nothing works.

How can I install it on Ubuntu 18.04.1?

  • Are you really running 18.10? Please edit your question to add the result of the terminal command: lsb_release -d Welcome to Ask Ubuntu. – chili555 Oct 5 '18 at 21:48
  • my fault... sorry – Sergio Oct 5 '18 at 21:52
  • 2
    "I tried all the things I found" is not detailed enough to help us. Please tell us what you tried, and what led you to believe that each attempt failed. I once found a blog claiming that soaking my keyboard in vinegar was a great idea, so "all the things I found" might have some rather mixed advice. – user535733 Oct 5 '18 at 23:43
4

You can install Celestia by compiling sourcecode by following below steps.

Install dependencies and required packages.

sudo apt install qtbase5-dev-tools qtbase5-dev libqt5opengl5-dev qtchooser libglu1-mesa-dev libpng-dev libjpeg-dev libtheora-dev liblua5.3-dev build-essential

Clone Source code from repository.

git clone https://github.com/CelestiaProject/Celestia

Compile Source Code. It will take long time 5-10 mintes.

cd Celestia && mkdir build && cd build
qmake -qt=5 PREFIX=/opt/celestia -o Makefile ../celestia.pro
make

Install Celestia.

sudo make install
  • 1
    Small typo, the last package should be build-essential and not build-essesntial. – Björn Tantau Jan 22 at 14:35
  • 2
    Follow below steps to install it on most recent version of Ubuntu: git clone https://github.com/CelestiaProject/Celestia && cd Celestia && git submodule update --init && sudo apt install qtbase5-dev-tools qtbase5-dev libqt5opengl5-dev qtchooser libglu1-mesa-dev libpng-dev libjpeg-dev libtheora-dev liblua5.3-dev build-essential libglew-dev libgl1-mesa-dev libeigen3-dev libfmt-dev cmake && mkdir build && cd build && cmake .. -DENABLE_QT=ON && make && sudo make install Sorry for the cramped command. Can't write a full answer due to community protection. – Anindya Chatterjee Jul 16 at 6:34
  • on ubuntu 19.04 mkdir build and cd build and the qmake line in this answer above have to be replaced by: sudo apt-get install libglew-dev libfmt-dev libeigen3-dev gettext cmake && rm CMakeCache.txt && cmake . && make && sudo make install Then you can start celestia by typing celestia-qt – jmarina Aug 26 at 12:39
2

To install Celestia in 18.04, open a terminal and do:

wget https://raw.githubusercontent.com/simbd/Scripts_Ubuntu/master/Celestia_pour_Bionic.sh && chmod +x Celestia* && sudo ./Celestia*

Celestia will then be available in 'Show Applications' or you can launch it from the terminal with:

celestia
  • If my answer has been helpful, please accept it: askubuntu.com/tour Then we may then also use it as the "already answered". – chili555 Oct 6 '18 at 12:43
  • 3
    The script isn't available anymore. And I wouldn't run some random script as root anyway. – Björn Tantau Jan 22 at 14:33
0

In addition to the previous answer qt libraries, I had to install:

sudo apt install libglew-dev
sudo apt install libeigen3-dev
sudo apt install libluajit-5.1-dev
sudo apt install libgtk-3-dev
sudo apt install libfmt-dev

# clone as in previous answer
git clone https://github.com/CelestiaProject/Celestia
cd Celestia && mkdir build && cd build

# install with cmake
cmake -o Makefile ../
make
sudo make install

#copy icon to system folder
sudo cp ../src/celestia/qt/data/celestia.png /usr/share/icons/hicolor/128x128/apps 

#make .desktop file
cat >$HOME/.local/share/applications/celestia.desktop <<'EOL'
[Desktop Entry]
Version=1.7.0
Type=Application
Name=Celestia
GenericName=Space simulator
Comment=Open source space simulator
TryExec=/usr/local/bin/celestia-qt
Exec=/usr/local/bin/celestia-qt
Categories=Astronomy;Science;Qt;
Icon=/usr/share/icons/hicolor/128x128/apps/celestia.png
MimeType=application/x-celestia-script
Terminal=false
EOL

#Make exec
cd $HOME/.local/share/applications/
chmod +x *.desktop

and launch with the windows key or with:

celestia-qt

For the record, I had to completely uninstall anaconda.

protected by Community Feb 10 at 21:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.