2

I've waited until 18.04.1 to post this to be sure it wasn't something that the .1 release would fix.

Please note this is a query about Teamviewer on Kubuntu, thus KDE - Plasma.

We have a corporate license for Teamviewer 9 that we don't want to "upgrade" to their new subscription model - it's a money pit.

Teamviewer 9 on 16.04 works great - in its own Wine shell. Sadly it doesn't work on 18.04.

On 18.04, the daemon and the executable start (ps -ef shows them running) but the front end doesn't show on the desktop.

Running the program from the shell on command line doesn't bring up anything of significance in the output.

We rely on our corporate branded Teamviewer license to assist our clients remotely and monitor their systems.

We use Kubuntu on the command and control systems and the hosts are a variety of Windows 7, 10, Server 2003 and 2008.

We cannot, I stress, upgrade to a newer version on our Kubuntu machines, because the over 200 systems that run our branded Teamviewer host only allow a 5 minute connection from a different version of Teamviewer. Branded hosts are locked to only accept connections from the same version of Teamviewer control session.

It's clear that the program is running with no errors on 18.04.1 but is just not showing the UI.

This problem is stopping us from upgrading most of our office machines to 18.04.

I suspect it's some bizarre problem with Wayland.

What type of tests, environment description and data do you need to help fix this?

I have access to both 16.04 and 18.04 LTS machines.

Thank you for your help.

  • Perhaps you could detail what TeamViewer have already tried, presumably you're paying them quite well they must have tried quite a few fixes? FWIW Kubuntu only has wayland available for testing, it doesn't use it yet for display AFAIAA. What graphics cards/drivers are you using, single monitor? and what alternatives have you tried. Does the free version work (works for me on Kubu 18.04.1, using amdgpu-kaveri)? – pbhj Oct 5 '18 at 20:39
  • Added how to package Appimage from deb file. – kukulo Jan 27 at 11:07
1

Although I don't know the exact source of the problem, I seems to be a combination of Linux, Teamviewer and libraries (dependencies) version. I tried different combinations and I have verified:

  • Any 12xxx_amd64 fails.
  • On Vanilla Ubuntu 18.04.1 and 18.04.1 server with Cinnamon 12.0.137452_i386 is OK, while 12.0.71510_i386 and 12.0.85001_i386 do not work.
  • On Kubuntu 18.04 (Plasma 5.12.6) 12.0.93330_i386 works, all other 12 don't.
  • 13.0.26559 (both amd64 and i386) works in both cases.

Bottom line: I suggest you try different subversions.

protected by Thomas Ward Dec 26 '18 at 17:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.