0

I have a Dell XPS 15 9570 running Windows 10.

I purchased an external Dell Thunderbolt 3 drive to enable me to boot Ubuntu without touching the Windows 10 install on the internal SSD.

I have configured the BIOS to allow booting from Thunderbolt 3 using the instructions here:

https://www.dell.com/support/article/uk/en/ukdhs1/sln301218/how-to-boot-to-an-external-device-using-usb-type-c-connection?lang=en

I have a USB key with the Ubuntu 18.04.1 installer.

I successfully booted from the USB key.

I can see the Thunderbolt 3 drive from the installer and the installation appears to complete successfully.

When I reboot, I can see the Thunderbolt 3 drive in the boot sequence in the Bios Boot options.

When I attempt to boot from the the Thunderbolt 3 drive a message pops up too quickly for me to read and the machine restarts.

Anyone got any experience of a similar setup?

  • Did you partition in advance and include an ESP - efi system partition on external drive. do not know if UEFI boots directly from Thunderbolt or if it is like USB where it only boots /EFI/Boot/bootx64.efi. But grub probably installed to internal drive's ESP and should boot from that. Just run the summary report, the auto fix sometimes can create more issues. Use ppa & your Ubuntu live installer flash drive. help.ubuntu.com/community/Boot-Repair Not sure what it will show with a Thunderbolt drive? – oldfred Oct 5 '18 at 17:21
  • I didn't partition in advance, rather I chose the 'erase disk and install Ubuntu' in the installer. It definitely wrote something to the internal drive because I noticed that there is now an 'Ubuntu' option in the BIOS boot sequence menu even when the Thunderbolt drive is disconnected. I tried selecting it but the machine just hangs. I will try the Boot repair tool! – user47227 Oct 5 '18 at 18:15
  • Found this that says you have to authorized Thunder bolt, but back then no utility to do that. Do not know latest info: superuser.com/questions/1298144/… – oldfred Oct 5 '18 at 19:14
  • Interesting. There is an option to disable Thunderbolt authentication in the BIOS and I disabled it. Still no joy. I have just run the boot repair tool and the output is here: paste.ubuntu.com/p/jfcxk6W3Fn – user47227 Oct 5 '18 at 19:21
  • I also tried the default repair but it failed. I do think you are correct about the ESP partition. – user47227 Oct 5 '18 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.