Possible Duplicate:
How do I reset my Unity configuration?

I have an Acer Aspire 5733Z-4851 laptop running Ubuntu 11.10.

I install CCSM back when I installed Ubuntu on the system. One day I was playing around with the different settings, when it seemed like the system locked up.

After restart of the computer; when trying to log into Unity 3D, the only thing that comes up after the desktop pattern is the menu bar that is normally hidden when Unity starts up.

It stays up, but the panel on the left hand side never comes up, nor do the icons at the top right of the menu bar.

The only way to shut the system down, or restart is to press the power button and bring up the menu.

I will note that Unity 2D boots up perfectly fine. I have tried to repair broken packages, but there does not seem to be any. I have tried both synaptic and recovery console. I just managed to get through a major update, that updated the kernal, and Unity. This did not fix the issue. I have also since removed CCSM hoping that would resolve the issue.

I imagine that when I upgrade the machine to 12.04 that it would fix the issue, since when that happens basically the entire system would be replaced.

Do any of you have any other things I can try to get the 3d environment working correctly again?

  • Not really an exact duplicate ... at least not of that question.
    – GalmWing
    Mar 3, 2012 at 5:43

1 Answer 1


So, you were messing with CCSM and Unity 2D works. Well, one of the most common mistakes is to disable the Unity plugin in ccsm.

From the Unity 2D you can configure ccsm and enable that plugin again.

Or you can simply try to run the command

unity --reset 
  • I tried the command unity --reset, it reset unity, 2d still works, but 3d still does not work. I deleted the ccsm, should I try to reinstall it?
    – user45168
    Mar 2, 2012 at 0:12
  • 1
    Update, I reinstalled ccsm, I found the unity plugin, and told it to enable it. It then had to disable 3 to 4 current plugins, after doing that I logged out of 2d, and logged into 3d. That did the trick, now 3d works, and loads perfectly. 2d also loads a bit faster and without little quarks.
    – user45168
    Mar 2, 2012 at 4:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.