2

I've been able to successfully finish building python 3.7.0 but one last optional module keeps slipping through the net! _dbm

What ubuntu or debian package is required for this?

The necessary bits to build these optional modules were not found:
_dbm

I've been able to include in the build _gdbm but not _dbm, why? I have installed libgdbm-dev (which solved _gdbm) but can't definitively find any other *dbm-dev package that is relevant for _dbm.

I would really appreciate a hand if anyone knows what I'm missing!

Environment:

  • Ubuntu 18.04
  • gcc8.2
  • python3.7.0 source
  • using configure --enable-optimizations --with-lto
4

I was able to satisfy the dbm requirement via this module

sudo apt install libgdbm-compat-dev

It looks like the older "dbm" files are moved to "gbdm-compat" package.

  • Will try it on the weekend. Will let you know how I go after. – DanglingPointer Jan 3 at 4:00
  • Worked with gcc 8.2.0 and python3.7.2! Thanks @Senthil – DanglingPointer Jan 13 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.