4

I have ubuntu bionic upgrade from xenial recently. After the upgrade, I didn't find my pgadmin4 application, so I reinstalled it. After clicking the pgadmin4 icon, the program not shown. So I try to run it through the terminal, then I found this problem:

randyka@orlansoft57-desktop:~$ pgadmin4 
Cannot mix incompatible Qt library (version 0x50501) with this library (version 0x50905)

Here is my qtchooser output :

root@orlansoft57-desktop:~/Public# qtchooser -list-versions
4
5
default
qt4-x86_64-linux-gnu
qt4
qt5-x86_64-linux-gnu
qt5

And this my qt5 list of library :

root@orlansoft57-desktop:~/Public# dpkg -l qt5* | grep ii
ii  qt5-default:amd64           5.9.5+dfsg-0ubuntu1 amd64        Qt 5 development defaults package
ii  qt5-gtk-platformtheme:amd64 5.9.5+dfsg-0ubuntu1 amd64        Qt 5 GTK+ 3 platform theme
ii  qt5-qmake:amd64             5.9.5+dfsg-0ubuntu1 amd64        Qt 5 qmake Makefile generator tool
ii  qt5-qmake-bin               5.9.5+dfsg-0ubuntu1 amd64        Qt 5 qmake Makefile generator tool — binary file

EDIT

Here the output of ldd

root@orlansoft57-desktop:~# ldd "$(which pgadmin4)" && dpkg-query -Wf '${Status;1} ${Package}:${Architecture}\n' libqt5\* | awk '$1=="i" {print $2}' | xargs -r -- apt-cache policy
    linux-vdso.so.1 (0x00007ffdb676b000)
    libpython3.6m.so.1.0 => /usr/lib/x86_64-linux-gnu/libpython3.6m.so.1.0 (0x00007fabe6fed000)
    libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007fabe67a6000)
    libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007fabe603d000)
    libQt5Network.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007fabe5cb1000)
    libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007fabe5566000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fabe51dd000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fabe4fc5000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fabe4bd4000)
    libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007fabe49a2000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007fabe4785000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fabe4566000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fabe4362000)
    libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007fabe415f000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fabe3dc1000)
    libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007fabe3b35000)
    libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007fabe3903000)
    libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007fabe3665000)
    libicui18n.so.60 => /usr/lib/x86_64-linux-gnu/libicui18n.so.60 (0x00007fabe31c4000)
    libicuuc.so.60 => /usr/lib/x86_64-linux-gnu/libicuuc.so.60 (0x00007fabe2e0d000)
    libdouble-conversion.so.1 => /usr/lib/x86_64-linux-gnu/libdouble-conversion.so.1 (0x00007fabe2bfc000)
    libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fabe28e6000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fabe78ff000)
    libGLX.so.0 => /usr/lib/x86_64-linux-gnu/libGLX.so.0 (0x00007fabe26b5000)
    libGLdispatch.so.0 => /usr/lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007fabe23ff000)
    libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007fabe214b000)
    libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007fabe1f1e000)
    libicudata.so.60 => /usr/lib/x86_64-linux-gnu/libicudata.so.60 (0x00007fabe0375000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007fabe0103000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fabdfdcb000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007fabdfba3000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007fabdf99f000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007fabdf799000)
    libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007fabdf584000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fabdf37c000)
libqt53danimation5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dcore5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dextras5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dinput5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dlogic5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dquick5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dquickanimation5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dquickextras5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dquickinput5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dquickrender5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53dquickscene2d5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt53drender5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5bluetooth5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5bluetooth5-bin:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5charts5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5concurrent5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5contacts5:
  Installed: 5.0~git20140515~29475884-0ubuntu24~7
  Candidate: 5.0~git20140515~29475884-0ubuntu24~7
  Version table:
 *** 5.0~git20140515~29475884-0ubuntu24~7 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5core5a:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5dbus5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5designer5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5designercomponents5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5glib-2.0-0:
  Installed: 1.2.0-5
  Candidate: 1.2.0-5
  Version table:
 *** 1.2.0-5 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5gstreamer-1.0-0:
  Installed: 1.2.0-5
  Candidate: 1.2.0-5
  Version table:
 *** 1.2.0-5 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5gstreamerquick-1.0-0:
  Installed: 1.2.0-5
  Candidate: 1.2.0-5
  Version table:
 *** 1.2.0-5 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5gstreamerui-1.0-0:
  Installed: 1.2.0-5
  Candidate: 1.2.0-5
  Version table:
 *** 1.2.0-5 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5gstreamerutils-1.0-0:
  Installed: 1.2.0-5
  Candidate: 1.2.0-5
  Version table:
 *** 1.2.0-5 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5gui5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5help5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5keychain1:
  Installed: 0.7.0-3
  Candidate: 0.7.0-3
  Version table:
 *** 0.7.0-3 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5location5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5location5-plugins:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5multimedia5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5multimedia5-plugins:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5multimediaquick-p5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5multimediawidgets5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5network5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5nfc5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5opengl5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5opengl5-dev:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5organizer5:
  Installed: 5.0~git20140515~29475884-0ubuntu24~7
  Candidate: 5.0~git20140515~29475884-0ubuntu24~7
  Version table:
 *** 5.0~git20140515~29475884-0ubuntu24~7 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5pas1:
  Installed: 2.6~beta-4
  Candidate: 2.6~beta-4
  Version table:
 *** 2.6~beta-4 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5positioning5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5positioning5-plugins:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5printsupport5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5qevercloud3:
  Installed: 3.0.3+ds-3
  Candidate: 3.0.3+ds-3
  Version table:
 *** 3.0.3+ds-3 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5qml5:
  Installed: 5.9.5-0ubuntu1.1
  Candidate: 5.9.5-0ubuntu1.1
  Version table:
 *** 5.9.5-0ubuntu1.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
libqt5quick5:
  Installed: 5.9.5-0ubuntu1.1
  Candidate: 5.9.5-0ubuntu1.1
  Version table:
 *** 5.9.5-0ubuntu1.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
libqt5quickcontrols2-5:
  Installed: 5.9.5-0ubuntu2
  Candidate: 5.9.5-0ubuntu2
  Version table:
 *** 5.9.5-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5quickparticles5:
  Installed: 5.9.5-0ubuntu1.1
  Candidate: 5.9.5-0ubuntu1.1
  Version table:
 *** 5.9.5-0ubuntu1.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
libqt5quicktemplates2-5:
  Installed: 5.9.5-0ubuntu2
  Candidate: 5.9.5-0ubuntu2
  Version table:
 *** 5.9.5-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5quicktest5:
  Installed: 5.9.5-0ubuntu1.1
  Candidate: 5.9.5-0ubuntu1.1
  Version table:
 *** 5.9.5-0ubuntu1.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
libqt5quickwidgets5:
  Installed: 5.9.5-0ubuntu1.1
  Candidate: 5.9.5-0ubuntu1.1
  Version table:
 *** 5.9.5-0ubuntu1.1 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
libqt5scintilla2-designer:
  Installed: 2.10.2+dfsg-4
  Candidate: 2.10.2+dfsg-4
  Version table:
 *** 2.10.2+dfsg-4 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status
libqt5script5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5scripttools5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5sensors5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5serialport5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5sql5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5sql5-ibase:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5sql5-mysql:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5sql5-odbc:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5sql5-psql:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5sql5-sqlite:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5sql5-tds:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5svg5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5test5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5texttospeech5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5versit5:
  Installed: 5.0~git20140515~29475884-0ubuntu24~7
  Candidate: 5.0~git20140515~29475884-0ubuntu24~7
  Version table:
 *** 5.0~git20140515~29475884-0ubuntu24~7 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5versitorganizer5:
  Installed: 5.0~git20140515~29475884-0ubuntu24~7
  Candidate: 5.0~git20140515~29475884-0ubuntu24~7
  Version table:
 *** 5.0~git20140515~29475884-0ubuntu24~7 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5waylandclient5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5waylandcompositor5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5webchannel5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5webengine-data:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status
libqt5webengine5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5webenginecore5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5webenginewidgets5:
  Installed: 5.9.5+dfsg-0ubuntu2
  Candidate: 5.9.5+dfsg-0ubuntu2
  Version table:
 *** 5.9.5+dfsg-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5webkit5:
  Installed: 5.212.0~alpha2-7ubuntu1
  Candidate: 5.212.0~alpha2-7ubuntu1
  Version table:
 *** 5.212.0~alpha2-7ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5websockets5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5webview5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5widgets5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5x11extras5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5xdg3:
  Installed: 3.1.0-5build2
  Candidate: 3.1.0-5build2
  Version table:
 *** 3.1.0-5build2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5xdgiconloader3:
  Installed: 3.1.0-5build2
  Candidate: 3.1.0-5build2
  Version table:
 *** 3.1.0-5build2 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libqt5xml5:
  Installed: 5.9.5+dfsg-0ubuntu1
  Candidate: 5.9.5+dfsg-0ubuntu1
  Version table:
 *** 5.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
libqt5xmlpatterns5:
  Installed: 5.9.5-0ubuntu1
  Candidate: 5.9.5-0ubuntu1
  Version table:
 *** 5.9.5-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status

EDIT

Here the output of installed pgadmin4

pgadmin4:
  Installed: 3.4-1.pgdg18.04+1
  Candidate: 3.4-1.pgdg18.04+1
  Version table:
 *** 3.4-1.pgdg18.04+1 500
        500 http://apt.postgresql.org/pub/repos/apt bionic-pgdg/main amd64 Packages
        100 /var/lib/dpkg/status
  • Welcome to Ask Ubuntu! Could you please edit your question to include the output of ldd "$(which pgadmin4)" and dpkg-query -Wf '${Status;1} ${Package}:${Architecture}\n' libqt5\* | awk '$1=="i" {print $2}' | xargs -r -- apt-cache policy? Thanks. – David Foerster Oct 5 '18 at 8:26
  • @DavidFoerster thanks for welcoming me. I have edited my question to add your request, and from my brief view, I did not find any error :( – Randyka Yudhistira Oct 5 '18 at 9:52
  • I found these libqt5contacts5, libqt5organizer5, libqt5versit5, libqt5versitorganizer5 using 5.0--- version. Is that the problem? – Randyka Yudhistira Oct 5 '18 at 9:56
  • Everything looks to be in order from that angle. How did you install pgadmin4 and did you do it before or after the upgrade to Ubuntu Bionic? What’s the output of which pgadmin4 and dpkg-query -S "$(which pgadmin4)" | awk -F '[,:] ' '{ for (i=1; i<NF; i++) if (!seen[$i]++) print $i; }' | xargs -r -- apt-cache policy? It would be worth a try to check package integrity too. – David Foerster Oct 5 '18 at 14:33
  • @DavidFoerster I have updated my question. I installed pgadmin4 after I upgrade my linux to bionic – Randyka Yudhistira Oct 10 '18 at 4:29
1

There appears to be a duplicate question and answer here in Ask Ubuntu but I'm not using the same software: Cannot mix incompatible Qt library

Solved the problem using this solution

I have fixed this issue doing the following:

  1. Installing the libs:

    apt-get install libxi-dev libxmu-dev
    
  2. (Re-)moving the Qt libs inside the Genymotion installation directory

    mkdir QtLibs && mv *Qt*.so* QtLibs
    

This last command will make Genymotion use the system's Qt libs.


Although the answer has 34 up-votes there are comments below it listing additional steps another user had to take.

| improve this answer | |
  • cannot find Qt libs inside pgadmin4 installation directory :( – Randyka Yudhistira Oct 11 '18 at 2:54
  • Is that the error message word for word? I can't find the same error – WinEunuuchs2Unix Oct 11 '18 at 2:59
  • word for word what this mean? – Randyka Yudhistira Oct 11 '18 at 3:04
  • Can you copy and paste the new error message exactly like you just did with word for word? – WinEunuuchs2Unix Oct 11 '18 at 3:06
  • root@orlansoft57-desktop:/usr/share/pgadmin4/web/pgadmin# pgadmin4 QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root' Cannot mix incompatible Qt library (version 0x50501) with this library (version 0x50905) Aborted – Randyka Yudhistira Oct 11 '18 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.