When I try to install any package with apt I get the following results:

Results of sudo apt-get -f install nmap :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
 nmap : Depends: liblinear3 (>= 2.01+dfsg) but it is not going to be installed
        Depends: lua-lpeg but it is not going to be installed
        Recommends: ndiff but it is not going to be installed
 osbuddy : Depends: default-jre but it is not going to be installed or
                    java6-runtime or
           Depends: jarwrapper (>= 0.5) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
  • I would check your sources - the first is there for xenial & in the version it needs (packages.ubuntu.com/search?keywords=liblinear3). I'd do an sudo apt update; I'd look at where you are getting nmap from (apt-cache policy nmap), maybe even try the suggest fix (no errors requiring it are in your paste) and check you are running Ubuntu! Do you get any errors for sudo apt update? If yo do get errors, please provide those (added to your question thru edit) and possibly provide the command & output for apt-cache policy nmap liblinear3
    – guiverc
    Oct 5, 2018 at 1:42
  • The applications that are in the depends come from the universe repo. Have you enabled the repo? sudo add-apt-repository universe then run sudo apt update. Then try the installation again.
    – Terrance
    Oct 5, 2018 at 3:03
  • There is not a package named osbuddy in 16.04, but I found an OSBuddy Debian package for RuneScape at rsbuddy.com. osbuddy_1.2_all.deb has default-jre as a dependency in 16.04. default-jre is a package in the default 16.04 repositories, so that looks ago, but maybe you also have either RuneScape or RuneScape client installed and RuneScape is causing the unmet dependencies.
    – karel
    Oct 5, 2018 at 6:52
  • I visited the official Download RuneScape webpage and found this line which looks like it's causing a problem in 16.04: echo "deb https://content.runescape.com/downloads/ubuntu trusty non-free" > /etc/apt/sources.list.d/runescape.list. The deb file for runescape-launcher needs to be edited and updated from 14.04 to 16.04. I messed up my packages and can't get them to work. Dependencies missing
    – karel
    Oct 5, 2018 at 7:56
  • 1
    I am unable to do a sudo apt update - there is a separate question on this: askubuntu.com/questions/1080995/… Oct 5, 2018 at 11:36


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy