1

I recently installed Ubuntu 18.04.1 as well as Xubuntu 18.04.1 and both have this issue.

I have a Nvidia GTX 670 for my graphics card for context.

  1. When I installed the OS, one of the first things I did was go to the addational drivers tab and installed the proprietary 390 driver listed and rebooted. After reboot I double checked it was still saying 390 driver, which it was. Cool. But checking in steam it's displaying the Nouveau driver, checked in the terminal and it's saying the same thing.

  2. After that I tried installing it via the PPA here:

ppa:graphics-drivers/ppa

And installed the 396 Nvidia driver version first, later the 390. Same results as above, installed just fine but no matter what I do, it wont actually use it.

  1. Next I tried downloading and installing it straight from the Nvidia website. This involved turning off the desktop interface so it wasn't in use during install, but the installer errors out midway through.

  2. The next thing I tried was everything above, but with the Nouveau driver black listed. Nope. If you blacklist the Nouveau driver it shows up as using a "VMWare" driver for graphics.

All of this has been done on both Ubuntu and Xubuntu. I'm at wits end. The last version of Ubuntu I used was 17.10 and installing the prop driver from the additional drivers screen worked perfect.

And today I installed the Ubuntu 18.10 Beta, went to the additional drivers menu and installed the Nvidia 396 Metapackage. After reboot I get a black screen after I type my password in.

  • Can you show your xorg.conf? Nouveau will try and do the work if the xorg.conf doesn’t have Nvidia using the device – TechdudeGames Oct 4 '18 at 21:09
  • 1
    Ensure you're not logging in using Wayland. Click on the little gear at the login screen to check that xorg ... is selected. – ubfan1 Oct 4 '18 at 23:15
  • @Matthew Neuforth Free open source drivers for Nvidia cards are more optimized than the proprietary ones, it consume less memory (less memory = faster) using the latest proprietary with Gnome 3 it may conflict with the login screen (like you said) and when it happens the login screen endlessly loop (or like you said black screen) not be able to continue to the Desktop, this problem appears only for Gnome 3 UI, sometimes it may ever appear after even for awhile of usage (days) try other UI, this problem appear many years ago and it still happening, blame Nvidia – GoldHaloWings Oct 5 '18 at 0:02
  • @TechdudeGames I'll get a copy of it once I get home. – Matthew Neuforth Oct 5 '18 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.