0

I am using ubuntu 16.04. To connect with external monitor and internet via USB, I had installed displaylink driver. It was working fine until I had run command sudo apt-get update and sudo apt-get dist-upgrade while installing few packages for setting up VPN. After taking the updates, I noticed that I was unable to connect to monitor screen and also internet had stopped working via USB. I tried uninstalling and reinstalling the displaylink driver but that is not helping.

I tried checking the dkms package details which is dependency of displaylink, if this can help somehow:

sudo dkms status

evdi, 4.2.29, 4.15.0-33-generic, x86_64: installed r8168, 8.041.00: added

Please suggest what could be wrong in this case.

Thank you

  • fyi: sudo apt-get update does not upgrade any software, it only updates the lists of software found in repositories, allowing you & your system to know upgrades are available (or no changes have been made). The lists are just text; and it's other commands that usually follow the 'update' that upgrade packages (such as upgrade, dist-upgrade etc) – guiverc Oct 4 '18 at 11:13
  • @guiverc I had run sudo apt-get dist-upgrade after sudo apt-get update. Updating the description for better clarity. Thanks – Amarjeet Kaur Oct 5 '18 at 4:50
0

I had this same problem and it turned out that after the kernel was updated, the necessary drivers that supported my motherboard ethernet (qualcomm atheros killer e220x) or either of my USB Ethernet dongles was no longer in the system (AXIS chipsets). Ultimately I found a thread that suggested I needed the ALX driver and when I tried to use modprobe to install it it could not find it.

I did a locate on 'alx' and it showed up in /lib/modules//kernel/drivers/net/ethernet/... for my older 4.4.0-130 kernel, but not for my newer 4.4.0-133 kernel.

I looked all over the web for where to get the alx drivers and they are not available except perhaps as a back-port. I welcome input from anybody who can add to this comment where they are at and how to download/build/install them for the 4.4.0-133 kernel.

Utlimately I reboooted the system, selected "Advanced booting....", picked the 4.4.0-130-generic kernel and booted with that and immediately all the drivers installed and I got my ethernet back.

I had been doing system updates for a while before reboot. No issues because I was still running the older kernel. Then one day had to reboot and when it came back my Internet was gone.

I hope this helps get someone on the right path and anybody who can contribute is totally welcome to do so, I have no ego... I would like to be able to use a newer kernel. I don't know why it stopped installing my ax and alx drivers. The kernel header files are there but the /lib/modules/uname -r/... is missing.

Changing the default boot kernel on grub is shown here:

Set "older" kernel as default grub entry

You can find the menu names by looking through this file: /boot/grub/grub.cfg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.