I am getting this SMG from cloud-init; with a clean installation of Ubuntu 18.04.1


enter image description here how Can I Fix this?

  • I had the same problem. It just happened when I rebooted the server. The login prompt is dead and the ssh connection timed out. I can only ping the server IP address. All suggestions of how to disable or uninstall Cloud-Init do not help as I cannot get in the box. Any special key combination to prevent the Cloud-Init from blocking the login?
    – Oliver
    Dec 11, 2022 at 7:45

3 Answers 3


You can configure getty@.service to wait until cloud-init.target has finished. Same concept as this answer, but waiting for network.target didn't work for me with the cloud-init messages.

mkdir /etc/systemd/system/getty@.service.d/
nano /etc/systemd/system/getty@.service.d/cloud-init_wait.conf #anything ending in .conf



  • This doesn't seem to work for me, is there anything else you need to do after creating the file? Apr 25, 2020 at 22:49

I had a similar problem with Ubuntu Server 20.04.2 on a Hyper-V machine. Jeff's answer almost worked for me. This post suggests creating the directory


instead of


The rest is identical. Create a .conf file inside this directory, add the contents



to it and reboot. That should do the trick.


The solution that worked with me, as shown here, just create an empty file, type :

sudo touch /etc/cloud/cloud-init.disabled

Not the answer you're looking for? Browse other questions tagged or ask your own question.