Upgraded to 18.04 from 16.04. I have a workplace printer connected through appsocket which stopped working.

Printer status is Idle-Filter failed.

Printing queue instantly goes to "stopped".

Right clicking on the printer shows "option finishings has value 3 and cannot be changed". I can't find any info on this error except one pdf to ignore the error.

The printer model Ricoh MP 2555 worked previously with the Ricoh MP C2800 driver. Now it works with neither 2800 or 2555.

The IP address of the printer pings fine. When I try and detect the printer on the network using IP address and I ask it to use the Ricoh MP 2555 driver, it asks for an additional driver which opens Ubuntu software (which never helps) and fails.

I tried changing drivers from "https://www.openprinting.org/printer/Ricoh/Ricoh-MP_2555" by providing the ppd file. It still doesn't help. var/log/cups/error.log doesn't tell much, or I don't get it.

Hope someone knows about this error or some kind of a generic solution.

3 Answers 3


I encountered the same problem. To track back its origin I looked into /var/log/cups/error_log

In my case, I discovered that the problem was caused by icc profiles used by ghostscript. I had the following error:

Started filter pstops (PID 26489)    
./base/gsicc_manage.c:1244: gsicc_open_search(): Could not find default_gray.icc    
./base/gsicc_manage.c:2261: gsicc_init_iccmanager(): cannot find default icc profile   
./base/gsicc_manage.c:1244: gsicc_open_search(): Could not find default_rgb.icc    
./base/gsicc_manage.c:2025: gsicc_set_device_profile(): cannot find device profile   
**** Unable to open the initial device, quitting.   

So what worked out for me has been to manually remove the icc profiles and then re-install libgs9-common (following this link: Broken ghostscript configuration):

sudo rmdir /usr/share/ghostscript/9.25/iccprofiles   
sudo apt-get install --reinstall libgs9-common   

Hope this helps

  • 1
    For searchers: this also fixed my problem with an EPSON XP-830 after upgrading from 16.04 to 18.04 Commented Oct 14, 2018 at 11:04
  • Fixed my problem with 18.04 and Brother MFC-7420: askubuntu.com/q/1082292/880132
    – Organis
    Commented Oct 15, 2018 at 19:58
  • I had no icc nor filter errors in my log file but in CUPS it showed Set job-printer-state-message to "Color Manager: no profiles specified in PPD", current level=INFO and the fix in the above answer worked for some reason. All the files are the same size, so I can't really work it out. Kubuntu 18.04.2 with Ghostscript 9.26.
    – pbhj
    Commented Jul 4, 2019 at 20:26

For Brother HL2140 printer, the following worked for me (on Ubuntu 18.04):

  1. Run this command to install drivers

    sudo apt install hpijs-ppds printer-driver-hpijs
  2. Open printer properties (Printers > Additional Printer Settings > (Right click on printer) Properties > Make and Model) and ensure Brother HL-2140 Foomatic/hpijs-pcl5e is there.

  3. Now Print Test Page should work fine.


The following worked for me under Kubuntu in 2021.

From application launcher

  • Printers--> Add printer --> Network --> Internet Printing Protocol (ipp)

  • ipp://PRINTER_IP_ADDRESS/ipp

  • Driver Ricoh -- My Model -- the PXL one.

But I checked in advance which drivers were supported (e.g. here or on Ricoh support ) and the drivers were already present in my system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .