0

I'm getting a networking issue that I'm having a very hard time diagnosing.

About two or three times a day, networking will just stop working completely. By this I mean ping returns:

$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 192.168.125.134 icmp_seq=1 Destination Host Unreachable
From 192.168.125.134 icmp_seq=2 Destination Host Unreachable

Sometimes running the ip command will just hang. systemctl restart networking has no effect. The only solution is to reboot the machine.

Interestingly, this only happens on my work network, not at home.

I'm running Ubuntu 18.04 (through the upgrade process) on a slightly old (2016?) Dell XPS 13". I have tried newer kernels (currently on 4.16.7-041607-generic) and various wifi drivers. The problem occurs both when running on wifi and when using ethernet.

Any suggestions? Anything I should be looking at?

Also, if anyone can figure out which ucode I should have for my wifi card, I'd be grateful. My wireless card is Intel Corporation Wireless 8260 (rev 3a) and the kernel is 4.16.

Update:

The last time it happened I was still able to run ip route etc. The results seem to indicate I'm losing the connection to the gateway:

$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.125.1   0.0.0.0         UG    20100  0        0 enx00e04c169188
0.0.0.0         192.168.125.1   0.0.0.0         UG    20600  0        0 wlp58s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 virbr2
...

$ arp -a
? (172.17.0.2) at 02:42:ac:11:00:02 [ether] on docker0
_gateway (192.168.125.1) at <incomplete> on enx00e04c169188
_gateway (192.168.125.1) at 00:18:0a:02:94:04 [ether] on wlp58s0

$ ping 192.168.125.1                                             
PING 192.168.125.1 (192.168.125.1) 56(84) bytes of data.                        
From 192.168.125.134 icmp_seq=1 Destination Host Unreachable                    
From 192.168.125.134 icmp_seq=2 Destination Host Unreachable                    
From 192.168.125.134 icmp_seq=3 Destination Host Unreachable  
...

Apologies for running route instead of ip route.

Update 2:

ip addr and ip route both started hanging again. Here's the output from strace:

$ strace ip route
socket(AF_NETLINK, SOCK_RAW|SOCK_CLOEXEC, NETLINK_ROUTE) = 3
setsockopt(3, SOL_SOCKET, SO_SNDBUF, [32768], 4) = 0
setsockopt(3, SOL_SOCKET, SO_RCVBUF, [1048576], 4) = 0
setsockopt(3, SOL_NETLINK, NETLINK_EXT_ACK, [1], 4) = 0
bind(3, {sa_family=AF_NETLINK, nl_pid=0, nl_groups=00000000}, 12) = 0
getsockname(3, {sa_family=AF_NETLINK, nl_pid=7214, nl_groups=00000000}, [12]) = 0
sendto(3, {{len=40, type=RTM_GETROUTE, flags=NLM_F_REQUEST|NLM_F_DUMP, seq=1539085900, pid=0}, {rtm_family=AF_INET, rtm_dst_len=0, rtm_src_len=0, rtm_tos=0, rtm_table=RT_TABLE_UNSPEC, rtm_protocol=RTPROT_UNSPEC, rtm_scope=RT_SCOPE_UNIVERSE, rtm_type=RTN_UNSPEC, rtm_flags=0}, {nla_len=0, nla_type=RTA_UNSPEC}}, 40, 0, NULL, 0

I'm starting to think it's a hardware failure in my laptop dock. Previously I had discounted this as the hangs occur whether I use wifi or ethernet through the dock. It's one of the few things that's different between my home setup (which doesn't hang) and my work setup (which does).

Update 3:

I purchased a new usb hub/dock, but it still happens. My original dock can take a 5v power supply, so I'll see if that helps.

Update 4:

Power supply didn't help. But it does seem to have stopped happening since, or at least have reduced significantly in frequency. I didn't update the kernel, but I think Ubuntu pushed a Thunderbolt firmware update for the Dell XPS that may have done the trick.

  • 1
    Look at the log messages produced by journalctl /usr/sbin/NetworkManager – waltinator Oct 3 '18 at 15:00
  • Nothing interesting there. – Adrian Mouat Oct 9 '18 at 11:33
2

A few ideas:

  1. Anything in dmesg or syslog around the time it stops working?
  2. An IP or MAC address conflict with another device on the network? There's some debugging options described here.
  3. "Destination Host Unreachable" usually means the kernel has no route to use. What does ifconfig, route -n, and arp -a return when it's stuck? Any differences between then and when it's working?
  4. "If I run an ip command, it just hangs." - this implies some sort of kernel issue... which ip commands are you attempting?
  • Thanks Rob :). I did try dmesg, but it didn't seem very interesting. Someone on twitter suggested running strace ip route, which I thought was good idea. I tried both ip route and ip addr. – Adrian Mouat Oct 3 '18 at 14:44
0

Looks like it was a firmware bug. Still not sure how this kills all networking, but it does. If you have similar issues, I would strongly suggest checking versions the fwupdmgr utility or similar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.