3

I installed ansible from its installation guide, but it creates a .ansible folder in the home directory of my user and when I would like to run a simple test command I give this error:

[ERROR]: Unable to set correct type for configuration entry for DEFAULT_LOCAL_TMP: Unable to
create local directories(/home/myuser/.ansible/tmp): [Errno 13] Permission denied:
'/home/myuser/.ansible/tmp'

ERROR! Invalid configuration settings

How I can fix this?

  • 1
    Were you able to find a fix for this? I think I'm running into this as well. – Paul Calabro Oct 4 '18 at 1:20
  • 1
    I removed ansible and all of its files (.ansible, python lib files), after reinstallation, it worked well. – Alex Oct 5 '18 at 1:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.