6

I am trying to upgrade kernel on my laptop and as I'm doing that very often I never had an issue until last time when I was able to fix the issue with running:

sudo dpkg --configure --pending

As there is a new kernel version, upgrade got stuck again and it's not moving from there:

...
Setting up linux-headers-4.15.0-36-generic (4.15.0-36.39) ...

I have also checked dmesg but I cannot find any issue there.

Command execution were as follows:

sudo apt update
sudo apt list --upgradable
sudo apt upgrade

I would like to skip the "workaround" part and be able to upgrade kernel/packages normally. Hope you can help me!

Please let me know if you need any logs.

Thank you!

Update:

As mentioned by cspan51, I don't have nvidia graphics, I have only intel.

I was able to fix the issue with restart of the laptop, and when fully ready I have started Software Updater, which seems does not have the same problem, tho I am not sure is this correct because under the hood I would say tools are the same.

Solution

Secure boot was the culprit but disabling it does not solve the problem since I don't want to disable it, so actually solution is to do package upgrade with Software Updater (GUI) instead of terminal apt-get/apt .. because in terminal version, it does never asks for secure boot password

10

I had the exact same problem with my laptop, which has a discrete Nvidia graphics card. I did some research and found that this is problem if fairly common if your machine has an Nvidia graphics card.

I was able to get past this problem by running killing all apt and dpkg processes: sudo killall apt && sudo killall dpkg

Then this to finish configuring the packages:

sudo dpkg --configure -a

After that, the setup finished like it normally does.

2
  • 1
    Thank you for your answer, but I have only intel graphics, will update an question. Please note that I have tried that but it did not work. – Filip C. Oct 2 '18 at 3:36
  • I had no nvidia graphics (on this computer at least) but the killall commands helped to get unstuck! Thanks a lot! – Gwang-Jin Kim May 6 '19 at 9:33
2

Disabling Secure Boot in bios helped in my case.

3
  • This seems more suited for a comment, next time try commenting to retreive more information – j-money Feb 25 '19 at 8:54
  • 2
    @j-money A solution should be posted as an answer, not a comment. – Melebius Feb 25 '19 at 10:50
  • Don't work, SecureBoot disabled – fireb86 Sep 12 '19 at 20:49
0

Killing all apt and dpkg processes is solved my problem. To find processes with ps aux | grep apt and ps aux | grep dpkg

After that kill -9 processnumber <id> to make it work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.