0

At the suggestion of a kind person answering my question I followed the suggestion of going to the following: Here are the title, link and and the terminal output. Still unable to install Kompozer. The Software Updater was run and it reported that the software was up to date.

Kompozer Installation step by step

Kompozer Installation step by step

This was the first line of the code entry and the reply: and it shows the file is already fully retrieved, nothing to do: This was repeated after entering the next lines of code: The errors come later, please look.

    computer@computer-HP-Compaq-8200-Elite-SFF-PC:~$computer@computer-HP-Compaq-8200-Elite-SFF-PC:~$ wget -c https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-dev_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
--2018-10-03 07:31:10--https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-dev_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
Resolving launchpad.net (launchpad.net)... 91.189.89.222, 91.189.89.223
Connecting to launchpad.net (launchpad.net)|91.189.89.222|:443... connected.
HTTP request sent, awaiting response... 303 See Other
Location: https://launchpadlibrarian.net/102977236/kompozer-dev_0.8~b3.dfsg.1-0.1ubuntu2_all.deb [following]
--2018-10-03 07:31:11--  https://launchpadlibrarian.net/102977236/kompozer-dev_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.229, 91.189.89.228
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.229|:443... connected.
HTTP request sent, awaiting response... 200 OK

The file is already fully retrieved; nothing to do.

The last two code entries reported error, here is one of them.

computer@computer-HP-Compaq-8200-Elite-SFF-PC:~$ sudo dpkg -i kompozer*.deb
dpkg: error processing archive kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb (--install):
 package architecture (amd64) does not match system (i386)
(Reading database ... 213540 files and directories currently installed.)
Preparing to unpack kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb ...
Unpacking kompozer-data (1:0.8~b3.dfsg.1-0.1ubuntu2) over (1:0.8~b3.dfsg.1-0.1ubuntu2) ...
Selecting previously unselected package kompozer-dev.
Preparing to unpack kompozer-dev_0.8~b3.dfsg.1-0.1ubuntu2_all.deb ...
Unpacking kompozer-dev (1:0.8~b3.dfsg.1-0.1ubuntu2) ...
Setting up kompozer-data (1:0.8~b3.dfsg.1-0.1ubuntu2) ...
dpkg: dependency problems prevent configuration of kompozer-dev: kompozer-dev depends on kompozer (>= 1:0.8~b3.dfsg.1-0.1ubuntu2).dpkg: error processing package kompozer-dev (--install):dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.5-1) ...Errors were encountered while processing:kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb kompozer-dev

I would appreciate help: All I know is to follow the examples that I can find here. Thank You (October 3, 2016)

Listed below are the previous attempts to install KompoZer. The newest attempt of Oct 3, 2018 is listed above. Trying to install KompoZer on 18.04.1 and 16.04.4 following suggestions from askUbuntu: First downloaded and extracted kompozer-0.8b3.lt.gcc4-2-686.tar.gz. from SourceForge. Now needed to know how to install the extracted files. Here are: Link Question Answer and the Unsucessful terminal output On how to install kompozer on ubuntu after downloading How to install kompozer on xubuntu after downloading 1 Answer If you googled, you would have got this in first place. Any way here you go.

    sudo apt-get install libatk1.0-0 libc6 libcairo2 libfontconfig1   libfreetype6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0  libidl0 libnspr4 libnss3 libpango1.0-0 libpng12-0 libstdc++6 libx11-6 libxft2 libxinerama1 libxrender1 libxt6 zlib

And the unsucessful terminal output:

[sudo] password for computer: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libidl0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:  libidl-2-0
Package zlib1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'libidl0' has no installation candidate
E: Package 'zlib1' has no installation candidate

Here is another trial with askUbuntu: Link, Question, Answer and Unsuccessful terminal output

Unable to install Kompozer in Ubuntu 16.04 For briefity only the last lines of code shown, no errors returned on previous lines, but the last four lines gave errors and for briefity just one of them will be shown, more can be given 64-Bit:

sudo dpkg -i libidl0_0.8.14-1_amd64.deb  
sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb
sudo dpkg -i kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
sudo dpkg -i kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb 

The terminal input/output entering the first sudo command these errors are encountered

sudo dpkg -i libidl0_0.8.14-1_amd64.deb 
dpkg: error processing archive libidl0_0.8.14-1_amd64.deb (--install):
package architecture (amd64) does not match system (i386)
Errors were encountered while processing:
libidl0_0.8.14-1_amd64.deb

And to be sure this is a 64 bit program and a 64 bit machine: I would appreciate any help. Thank you

  • Please, for your own interest, make an effort to explain and format your questions nicely, so that people can understand and answer you more easily – M. Becerra Oct 2 '18 at 12:10
  • The input and the output you included in your question are clearly not connected, please re-read the posts where you have seen those answers, specially askubuntu.com/questions/376986/… – M. Becerra Oct 2 '18 at 12:12
  • Here they are: And as I said, please see that I feel my inputs are related to the output: If you can guide me further, please do so. – Sunclock2018 Oct 3 '18 at 13:17
2

It looks like you tried to run an incorrect command that looks like this:

sudo apt install libx Unable to install Kompozer in Ubuntu 3 11-6

Instead of running a command that looks like this:

sudo apt install libx11-6  

Somehow or another you accidentally pasted the string Unable to install Kompozer in Ubuntu 3 in the middle of the command, so let's start over from the beginning and run the following commands in Ubuntu 18.04. For Ubuntu 16.04 go back to the same link and follow the instructions for installing Kompozer in 16.04 instead of 18.04.

sudo apt install libatk1.0-0 libc6 libcairo2 libfontconfig1 libfreetype6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0 libnspr4 libnss3 libpango1.0-0 libstdc++6 libx11-6 libxft2 libxinerama1 libxrender1 libxt6 zlib1g  
wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8%7Eb3.dfsg.1-0.1ubuntu2_all.deb
wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8%7Eb3.dfsg.1-0.1ubuntu2_amd64.deb
wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_amd64.deb  
wget https://launchpad.net/ubuntu/+archive/primary/+files/libpng12-0_1.2.54-1ubuntu1_amd64.deb  
sudo apt-get install ./libidl0_0.8.14-1_amd64.deb  
sudo apt-get install ./libpng12-0_1.2.54-1ubuntu1_amd64.deb
sudo apt-get install ./kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
sudo apt-get install ./kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb   

Note that first you need to download libidl0_0.8.14-1_amd64.deb with wget before you can install it with sudo apt-get install ./package.deb

To start kompozer, open the terminal and run kompozer

  • I am new to this, so I interpreted the command you suggested to download as "wget libidl0_0.8.14-1_amd64.deb" and that gave me --2018-10-01 15:45:01-- libidl0_0.8.14-1_amd64.deb Resolving libidl0_0.8.14-1_amd64.deb (libidl0_0.8.14-1_amd64.deb)... failed: Name or service not known. wget: unable to resolve host address ‘libidl0_0.8.14-1_amd64.deb’ – Sunclock2018 Oct 1 '18 at 19:46
  • That's wrong. Ther correct command is wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_amd64.deb Make sure that each command is pasted correctly before you run it. The links to download the 4 files that should be downloaded by wget are all live and all 4 links work. – karel Oct 1 '18 at 19:55
  • I have done that, Thank you. I have looked for a start icon in "show applications" and on the left hand tool bar. I have searched for kompozer. I will try it again. Again Thanks – Sunclock2018 Oct 1 '18 at 20:12
  • Errors were encountered while processing: kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb To my best I copied your corrected code line and then the 9 lines of code: I have the 64 bit Bionic Beaver 18.04.1 installed on an HP 8200, which is 64 bit. but I see errors that make me question the computer or the software package architecture (amd64) does not match system (i386) This error shows up in a few of the returns from the entry of a line of code. – Sunclock2018 Oct 1 '18 at 20:26
  • @Sunclock2018 I found an error in the last command which I fixed so it should work now. – karel Oct 5 '18 at 21:50
0

Thank you: I have poured over the link although I can't see how to use its content: Listed are every command I see.

sudo dpkg --configure -a
foo@foo:~$ sudo apt-get install -f
dpkg --get-selections | grep hold
sudo aptitude install <packagename>
sudo aptitude -f install <packagename>
sudo apt-get autoremove

I want to assured you I have looked at every line: 3rd through 5th are unfamilar to me and I don't understand how they may fix a broken package. Thank you

  • aptitude doesn't simply fix things by itself. Instead aptitude suggests actions that you could take that could fix the problem. aptitude can be a bit difficult to master, so I made a list of simpler replacements for aptitude for beginners: askubuntu.com/questions/223237/… – karel Oct 11 '18 at 11:24
  • computer@computer-HP-Compaq-8200-Elite-SFF-PC:~$ sudo apt-get -f install [sudo] password for computer: Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 17 not upgraded. computer@computer-HP-Compaq-8200-Elite-SFF-PC:~$ sudo aptitude install libx11-6 sudo: aptitude: command not found computer@computer-HP-Compaq-8200-Elite-SFF-PC:~$ Tried the commands as seen on your suggested link for beginners; the terminal returned aptitude not found. copied from the link. Thank you for your help – Sunclock2018 Oct 13 '18 at 11:29

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.