From the usual Ubuntu login screen, I click on my name, type my password, and press ENTER. Screen goes black...and stays black. I cannot get to my desktop.

If I SSH from another computer and run htop, I can see /usr/bin/gnome-shell is eating up 100% of a single core. Other than gnome-shell, the system is completely idle. Load average in htop is exactly 1.00.

htop showing gnome-shell at 100%

Earlier today I left it there for over an hour, but no change. Since then I've also tried rebooting, but same results. This desktop was previously working fine, not sure what I messed up. How can I debug what is happening?


On a whim, because I had seen some updates to the nvidia drivers, I tried to switch to nouveau. I have no idea if I did so correctly, but it solved the problem. This is what I ran:

sudo apt-get purge nvidia-\*
sudo apt-get autoclean
sudo apt-get autoremove
sudo reboot

At this point, everything seems to be working again, and looking at the "Additional Driver" tab of "Software & Updates", I see that this computer is now using Nouveau instead of NVIDIA.

| improve this answer | |
  • Some weeks ago I had a different issue (extremely slow 3D performance) on Debian. I resolved it by purging and reinstalling nvidia drivers. So maybe your problem will be solved even after installing nvidia drivers again. However if you don't really need them (e.g. no heavy gaming) I suggest to stay with nouveau. – scai Oct 1 '18 at 8:33
  • I have a similar issue with nvidia drivers. Can you login if you reactivate the nvidia binaries? – Captain Giraffe Oct 1 '18 at 13:27
  • @CaptainGiraffe Re-activing the nvidia drivers results in the same problem. – Stéphane Oct 2 '18 at 8:59

My advice is first try logging in with a new user, you can create the user over SSH:

sudo adduser testuser

Try logging in with that new user. If gnome-shell is still taking up 100% and not working, then there is likely a problem with that package, possibly a corrupt disk could have cause the /usr/bin/gnome-shell binary to become corrupted, you can check this by running:

sudo debsums -s

If it prints anything then those package files have been corrupted (or modified by a user/program for some reason, which they shouldn't be)

Lastly if you are able to login as a test user but cannot with your existing account, try renaming these files in your home directory to something else and logging in to narrow down which files are causing the problems:

  • ~/.config
  • ~/.gconf
  • ~/.local
| improve this answer | |
  • 1
    It is very very unlikely that the gnome shell binary becomes corrupted or is changed by another program. More likely are wrong (system-wide) configurations or problems with the hardware (e.g. graphics driver). Especially for new releases you may have triggered a bug, which possibly should be reported. When you are sure, it is not caused by your per-user configuration or you changed related configurations in /etc – allo Oct 1 '18 at 9:33

I had the same issue and disabling login on start up sort of fixed it.

  • Go to Settings > Details > Users
  • Click on Unlock, enter password
  • Enable automatic login

Then reinstall nvidia drivers, but note that if you log out of your current session and login again, you're gonna run into the black screen issue again (at least from what happened too me). Locking screen and logging back in works fine though.

| improve this answer | |
  • How do you suggest I get to Settings > Details > Users when I cannot login? – Stéphane Oct 2 '18 at 8:54
  • Are nvidia drivers still installed? Does the login screen pop up? If the answer is yes, try the following.... Don't enter password in login screen. Enter Ctrl+Alt+F2 to open a shell prompt, enter username and password, run " sudo apt remove nvidia-* *" to uninstall nvidia drivers, reboot. You should be able to login – Nate Oct 3 '18 at 0:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.