2

On two different systems, and on Kubuntu 16.04 and 18.04, I do this:

Click Desktop Toolbox > Configure Desktop > Tweaks

I un-check Show the desktop toolbox

I want to get rid of desktop icons, too, so I do:

Configure Desktop > Location > check Show files linked to the current activity

NOW, I have a clean desktop! Yay!

Next time I log in, the toolbox is there, and so are the icons. I can manually remove them, &c.

This happens on:

  1. My work computer, which is a clean install of Kubuntu 18.04
  2. My home computer, which has been upgraded multiple times, when it ran 16.04
  3. My home computer, upgraded to Kubuntu 18.04
  4. My home computer, upgraded to Kubuntu 18.04, and "reset" via rm -rf ~/.config/plasma*

How do I get me a clean desktop upon login?

UPDATE: It appears that something keeps rewriting ~/.config/plasma-org.kde.plasma.desktop-appletsrc:

0-21:02 djh@noneedto ~> grep showToolbox ~/.config/plasma-org.kde.plasma.desktop-appletsrc
0-21:03 djh@noneedto ~> ls -l ~/.config/plasma-org.kde.plasma.desktop-appletsrc
-rw------- 1 djh djh 4465 Oct  2 21:01 /home/djh/.config/plasma-org.kde.plasma.desktop-appletsrc
0-21:03 djh@noneedto ~> touch ~/.config/plasma-org.kde.plasma.desktop-appletsrc
0-21:03 djh@noneedto ~> grep showToolbox ~/.config/plasma-org.kde.plasma.desktop-appletsrc
0-21:03 djh@noneedto ~> echo doing the GUI
doing the GUI
0-21:03 djh@noneedto ~> grep showToolbox ~/.config/plasma-org.kde.plasma.desktop-appletsrc
showToolbox=false
[ . . . reboot . . . ]
0-21:06 djh@noneedto ~> ls -l ~/.config/plasma-org.kde.plasma.desktop-appletsrc
-rw------- 1 djh djh 4465 Oct  2 21:06 /home/djh/.config/plasma-org.kde.plasma.desktop-appletsrc
0-21:06 djh@noneedto ~> grep showToolbox ~/.config/plasma-org.kde.plasma.desktop-appletsrc
  • 1
    I understand your frustration but you should ensure that you have clear and concise questions with proper titles that describe the issue. We're all here to help and the KDE devs will likely fix any issue if there is a bug. – Kristopher Ives Oct 1 '18 at 1:01
  • I think the original question was more accurately descriptive but whatever suits your prescriptivism works just fine for me. Thanks! – dannyman Oct 2 '18 at 22:26
  • You may want to check out the Ask Ubuntu Conduct Guidelines for why this title was edited. – Kristopher Ives Oct 2 '18 at 22:29
  • Ah, yes, "Be clear and constructive when giving feedback" ... I updated the title again, to clarify the nature of the problem. – dannyman Oct 3 '18 at 4:11
1

The icons can be hidden by right clicking the desktop and going to Configure Desktop (Change Desktop Background in some older versions) then changing Layout to Desktop instead of Folder View

enter image description here

It's possible you have some kind of permissions issue with your ~/.config directory causing the tweak toolbox setting not be saved between sessions. The checkbox you are setting is the correct way to disable the desktop toolbox. The setting is stored in ~/.config/plasma-org.kde.plasma.desktop-appletsrc with a line like this:

showToolbox=false

My advice is check that file and it's contents and if it's not being updated when making the change look at the permissions for that file and it's parent directories, try running the desktop settings applet in a command line window, and ultimately file a bug on https://bugs.kde.org if needed.

  • I'm on Neon too and you're right, I just messed up in typing it. – Kristopher Ives Oct 1 '18 at 21:21

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.